Mobileread
Hacks Changing the reader font without a hack [K3]
#1  NiLuJe 09-20-2010, 01:05 PM
Hello again! In this quick little post I'll explain how to change the font used in the reader to use a custom font, without having to use the proper full-fledged font hack.

Note: FW 3.x/4.x only.

It's not as complete/powerful as the full hack, you'll only be able to change the reader font, exactly the same way as the official font switch in the [Aa] menu.

First, make sure your Kindle is on the Home screen before plugging it to your computer.

You'll have to edit the reader config file, which is located, once your Kindle is plugged to your computer, in the system\com.amazon.ebook.booklet.reader folder. (Att, Windows users: depending on your Windows Explorer settings, this folder might be hidden. To workaround this without messing with Windows Explorer settings, just enter the folder name in the address bar). Once you're there, open the reader.pref file in your favorite UNIX-aware text editor. (Yes, it's the same file where you can tweak the horizontal margins)

In there, just before the
Code
FONT_FAMILY=
line, add:

Code
ALLOW_USER_FONT=true
and replace the FONT_FAMILY= line with:

Code
FONT_FAMILY=alt
Once that's done, we'll have to put our custom fonts where the Kindle expects them...

In the root of your Kindle, create a folder named fonts. In this new folder, you'll have to put your custom fonts with very specific names, according to their style, kinda like with the Fonts hack.

Regular: alt-Regular.ttf
Bold: alt-Bold.ttf
Italic: alt-Italic.ttf
Bold Italic: alt-BoldItalic.ttf

And that's it! Eject your Kindle, and Restart it. (Or, if you can, just restart the framework).

You Kindle should now be using your custom font instead of the usual Serif/Serif Condensed/Sans Serif .

As always with this kind of tinkering, it won't survive if you try to change this specific setting (font choice) in the [Aa] menu. But every other setting (ie. font size) in the menu should be fine .

On a sidenote, Amazon also has user screensavers ready under their sleeves, but I haven't been able to enable this without a jailbreak... (Cf. this & that).

Note that the Kindle software now uses TrueType bytecode hinting instructions, and hint at the strongest level possible. (In terms of FT/FC settings: hintstyle=hintfull, hinting=true & autohint=false).

OpenType CFF fonts work fine too, without converting them .
Reply 

#2  bojzi 09-20-2010, 01:34 PM
Thank you!

This works great, even allows you to change back to default fonts very easy.
Reply 

#3  [Ahmed] 09-20-2010, 01:55 PM
Works.

You don't even have to stay away from the aA-menu. Changing font size etc works perfectly fine. Only changing the fonts will revert the change.

edit: Now I just have to find a good looking Garamond that comes as a TTF.
Reply 

#4  DAVID FION 09-20-2010, 02:22 PM
merci beaucoup !
Reply 

#5  911jason 09-20-2010, 04:13 PM
You continue to amaze NiLuJe!!! Going font shopping now...

P.S. I like the K3's sans-serif font quite a bit, but the customizer in me has to at least give this a try! =)
Reply 

#6  diokdin 09-20-2010, 05:36 PM
thanks for this, I might try this out thouh I like the san serif fine. But it's still wonderful to have this option.
Reply 

#7  daffy4u 09-20-2010, 07:01 PM
This one isn't working for me. I used notepad++ to edit the file. After adding the fonts in the new font folder, ejecting and restarting I had the same font (which I could not change via Aa) and none of my content would open.

Even after reverting back to the original version of reader.pref file, I still could not open any content. I've just done a factory reset and all is well again.

Here are some images, maybe someone could tell me where I made my misstep.
readerpred_before.PNG readerpref_after.PNG fonts in folder.PNG 
Reply 

#8  TomF 09-20-2010, 08:38 PM
Edit: post deleted
Reply 

#9  flandroid 09-20-2010, 09:35 PM
Quote daffy4u
Here are some images, maybe someone could tell me where I made my misstep.
Hyphens, not underscores, chief.
Reply 

#10  daffy4u 09-20-2010, 10:01 PM
Quote flandroid
Hyphens, not underscores, chief.
Ah-ha! Thanks, I'll give it another try.
Reply 

  Next »  Last »  (1/11)
Today's Posts | Search this Thread | Login | Register