Mobileread
setting time on Kindle
#1  anzacman 05-24-2010, 08:34 PM
I have a Kindle but I note that the time settings are not current to my time zone, can this be reset to coincide with my area. Any help appreciated.
Reply 

#2  Snorkledorf 05-24-2010, 08:51 PM
It does it automatically over Whispernet. After I reset the Kindle I sometimes get confused by my books starting to sort all wrong, but turning Whispernet on again so the clock can reset fixes the problem.

That said, there have been times when it took ages for it to finally get around to changing the clock, even with Whispernet on for over a day...
Reply 

#3  Jonas777 05-25-2010, 08:15 AM
Make sure whispernet is on and wait for a day as Snorkledorf said. If you still got the wrong time you can try to change which network it connects to and then wait again. May or may not work since not all networks send out the time(zone).
Those are the only official way to set the time.
There is probably another way if you know your way in an Linux system: Install SSHD, connect to it from a computer and then set the time as you would on any linux system. I have not verified this but think it would work.
Reply 

#4  mgmueller 05-25-2010, 08:51 AM
Quote anzacman
I have a Kindle but I note that the time settings are not current to my time zone, can this be reset to coincide with my area. Any help appreciated.
If Whispernet isn't available (no reception, outside US with US-only Kindle, ...): USB-Network hack and manually setting date/time.
Perfectly explained in the USB-Network sticky.
Reply 

#5  jerome 05-25-2010, 09:23 AM
Quote mgmueller
If Whispernet isn't available (no reception, outside US with US-only Kindle, ...): USB-Network hack and manually setting date/time.
Perfectly explained in the USB-Network sticky.
actually, you could just enable wireless connection for a couple of minutes. Kindle (firmware ver. 2.3) will retrieve information from available wireless networks and set the time to the local area accordingly.

you could check if there's wireless information by going to setting page and type 611 (US version) or 311 (Global version).
Reply 

#6  Dharmabum 05-25-2010, 09:34 AM
Quote mgmueller
Perfectly explained in the USB-Network sticky.
Not seeing any sticky that fits that description.
Reply 

#7  mgmueller 05-25-2010, 09:38 AM
Quote Dharmabum
Not seeing any sticky that fits that description.
Sorry, in the developer's corner - and not a sticky: http://www.mobileread.com/forums/showthread.php?t=49350
Reply 

#8  Jonas777 05-25-2010, 02:46 PM
Quote jerome
actually, you could just enable wireless connection for a couple of minutes. Kindle (firmware ver. 2.3) will retrieve information from available wireless networks and set the time to the local area accordingly.
Only true for some parts of the world. I happen to live in one part where the network does not supply time.
Reply 

#9  Dharmabum 05-25-2010, 06:38 PM
Quote mgmueller
Sorry, in the developer's corner - and not a sticky: http://www.mobileread.com/forums/showthread.php?t=49350
Thank you.
Reply 

#10  Snorkledorf 05-25-2010, 08:05 PM
Quote Jonas777
Make sure whispernet is on and wait for a day as Snorkledorf said. If you still got the wrong time you can try to change which network it connects to and then wait again
Good point; sometimes switching wireless networks has helped when my clock wouldn't update. Forgot to mention I'd tried that.
Reply 

Today's Posts | Search this Thread | Login | Register