Mobileread
How to keep kindle alive? without physical touch? (using xdotool)
#1  zxczxc 08-24-2013, 04:54 AM
hi, i control my kindle via ssh, to turn the pages, this is done via xdotool.
after 10 minutes or so, the paperwhite goes to sleep, since it has not recieve any touch. because the 'touch' it is getting is form xdotool, not the screen.

i do not want to disable the kindle from sleeping because, i still want my kindle to sleep. i do not want to have to remember to disable and then renable the sleeping each time i want to use my kindle remotely.

is there any command that can be sent by terminal to keep the kindle alive?
as in, send the command, and then the kindle thinks it just received input, and won't sleep for 10 minutes, unless you send this again.

thanks a lot, i appreciate it
Reply 

#2  aditya3098 08-24-2013, 07:22 AM
Disable screensaver:
lipc-set-prop com.lab126.powerd preventScreenSaver 1
Enable screensaver:
lipc-set-prop com.lab126.powerd preventScreenSaver 0
Reply 

#3  twobob 08-24-2013, 07:24 AM
It's in the KUAL HELPER package, "As standard"

Prevent / Allow screensavers.
Reply 

#4  knc1 08-24-2013, 09:58 AM
PS: Your Kpw is not 'going to sleep' it is only clearing the screen.
If it actually went to sleep, your ssh link would stop responding.
Reply 

#5  nasser 08-24-2013, 12:15 PM
Quote knc1
PS: Your Kpw is not 'going to sleep' it is only clearing the screen.
If it actually went to sleep, your ssh link would stop responding.
I think zxczxc is describing a peculiar scenario wherein:
  1. He's actually reading stuff on the PW (either directly or through vnc) and..
  2. He's doing page turning without touching the PW screen using xdotool(how?) and..
  3. He wants a means to 'wake up' the PW when it goes into screensaver mode

Obviously the KUAL helper buttons to disable/enable screensavers are not convenient here..

So.. the solution is..

Send command
Code
/usr/bin/powerd_test -p
This either 'wakes up' the PW or puts it into screensaver mode..
meeting zxczxc's requirement of..
Quote
is there any command that can be sent by terminal to keep the kindle alive?
as in, send the command, and then the kindle thinks it just received input, and won't sleep for 10 minutes, unless you send this again.
Reply 

#6  twobob 08-24-2013, 01:06 PM
you're not wrong. In fact IIRC I think it was me that setup that horrible xdotool hack with zxczxc. (It's on a thread somewhere) EDIT oh yeah: http://www.mobileread.com/forums/sho...47&postcount=1

TBH I think he would be best using the
lipc-set-prop com.lab126.powerd preventScreenSaver 1

but you are correct. one can simulate a button push in that manner.
Reply 

#7  nasser 08-24-2013, 01:47 PM
Quote twobob
you're not wrong. In fact IIRC I think it was me that setup that horrible xdotool hack with zxczxc. (It's on a thread somewhere) EDIT oh yeah: http://www.mobileread.com/forums/sho...47&postcount=1

TBH I think he would be best using the
lipc-set-prop com.lab126.powerd preventScreenSaver 1

but you are correct. one can simulate a button push in that manner.
Well.. his requirement was also:
Quote
i do not want to disable the kindle from sleeping because, i still want my kindle to sleep. i do not want to have to remember to disable and then renable the sleeping each time i want to use my kindle remotely.
I'm quite lazy myself.. but don't know whether I'd go to the extent of setting up a bluetooth remote working through an android phone to control page turns on the Kindle..
Reply 

#8  twobob 08-24-2013, 02:32 PM
I have to agree. your solution is better in this case.

Unsure if the wifi dies though...
zxczxc will be able to tell us
Reply 

#9  zxczxc 08-24-2013, 03:34 PM
oh wow all these replies!

ok, my mistake... when i meant sleep, i meant screensaver.
in my setup (yes thanks again twobob, you helped me a lot!) i will be reading, and then eventually the screensaver will turn on, and the screen will go dark.

if i was physcially pressing the screen, (i'm not sure how exactly but) the kindle receives that the screen was touched and so resets the timer that the screensaver will show.
using the way i read books, this does not happen.

i did not think i wanted to disable the screensaver, i knew this was a possibility, but i still want the screen saver to happen, just, when i am not using the device. when i am turning the pages via ssh, the kindle things i am not using the device.

if i disable the screensaver, and close my cover (with magnet), will the kindle then show the screensaver and dim the light?
does it just dim the light? or does nothing happen at all?

if so, sure, i could disable the screensaver, but, i do not want to enable it when i am done reading. i just want to fall asleep.

there is no command, or anything (that you guys know) that will make the kindle think i touched it? or, no way to reset the timer that must count down until the screensaver is shown?


-edit. at the moment, when this happens, i simply have to manually press the power button, then continue reading. (just for information, i am not disabled or anything, just, i find it much more relaxing, ergonomic, and easier to not have to hold the kindle in bed)
Reply 

#10  NiLuJe 08-24-2013, 04:45 PM
@zxczxc: IIRC, there's a lipc call to reset the timeout. Never tried it myself, and you will still need to periodically launch this command, so that's not terribly awesome, but it might work.

EDIT:
Code
lipc-set-prop com.lab126.powerd -i touchScreenSaverTimeout 1
Works, the default tier 1 timeout is 600s.

May also want to investigate what the hell defer_suspend & suspend_grace do, but I suspect, as the name implies, that they're mostly for the tier 2 timeout (suspend).
Reply 

  Next »  Last »  (1/3)
Today's Posts | Search this Thread | Login | Register