Mobileread
Kindle Touch phoning home when first connecting to a WiFi network
#1  bhaak 08-19-2012, 10:15 AM
Today, I set up a new wifi network at home. Almost everything worked as before, only my KT didn't connect properly with it.

After finding out that it actually did correctly connect to the wifi network but the KT framework somehow failed to recognize that, I suspected my custom firewall rules (see this thread) to be the culprit.

A little tcpdump session later, it looks like that the KT tries to verify a new wifi connection by downloading a file from Amazon: http://spectrum.s3.amazonaws.com/kindle-wifi/wifistub.html

The dialog between KT and Amazon is completely normal browser/webserver stuff:

Code
GET /kindle-wifi/wifistub.html HTTP/1.1
User-Agent: Mozilla /5.0 (Linux; like iPhone; U; en-US) AppleWebKit/528.5+ (KHTML, like Gecko, Safari/528.5+) Version/4.0
Accept: */*
Host: spectrum.s3.amazonaws.com
HTTP/1.1 200 OK
x-amz-id-2: 3+3Tnnwb/1HjOIyunxC9e7WbaNWv7hzMMlEaF35j4tmB3dv0AZMhb666/OMO1jxk
x-amz-request-id: 8CD37DDE1E738221
Date: Sun, 19 Aug 2012 12:11:20 GMT
x-amz-meta-s3fox-filesize: 419
x-amz-meta-s3fox-modifiedtime: 1263439412000
Last-Modified: Thu, 14 Jan 2010 03:23:46 GMT
ETag: "4384cffb0af0f42d033cc1465f016427"
Accept-Ranges: bytes
Content-Type: text/html
Content-Length: 419
Server: AmazonS3
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html>
<head>
<title>Kindle Reachability Probe Page</title>
<META http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<!--81ce4465-7167-4dcb-835b-dcc9e44c112a created with python 2.5 uuid.uuid4()-->
</head>
<body bgcolor="#ffffff" text="#000000">
81ce4465-7167-4dcb-835b-dcc9e44c112a
</body>
</html>
As far as I can tell, this file is the same since 2010 (see last-modified header) and doesn't get dynamically generated. This suggests that other Kindles also do this? But I didn't find lots on the net about this, only some japanese pages. The KT doesn't seem to send any overly sensitive data, the http headers don't contain anything that looks specific to my Kindle Touch. I guess, Amazon only sees the IP address.

For testing this behavior, you can go to Menu -> Settings -> Wi-Fi Networks, select the wifi connection you want to test and select "Forget" in the following dialog. When setting up the network again the KT will download the file.
Reply 

#2  qlob 08-19-2012, 02:35 PM
I believe my Kindle 3 also does this.
Reply 

#3  twobob 08-19-2012, 02:59 PM
Yep. this is standard.

This is what someone might do. (This is for a 3 I have no idea about other devices yet)

add the TLD with subdomain spectrum.s3.amazonaws.com to my host table to make that subdomain point to my devices internal

spectrum.s3.amazonaws.com 127.0.0.1
should do it.

grab a copy of the exact content of file. (looks up, oh there it is)

ape the folder structure above and make the /kindle-wifi/wifistub.html somewhere on the FAT /mnt/us/www seems a likely candidate

start the Inetd from Busybox (the one with the usbnetworking has this capability) with the relevant arguments (check them with help) to make your device resolve port 80 traffic on your local device.

I often get a flaky external connection up on the hills which kills my wifi DUH! no.

CAVEATS:

I have no idea if that will work. I didn't test it. pls don't ask for support.

and you would have to start the inetd everytime (if you had rebooted since the last time) you had this issue

but that has to be more fun that no Wifi because some daft bit of xthml wont load from some remote location. Barmy

HTH.
Reply 

#4  fulltlt 07-17-2014, 10:42 AM
Here's the solution for the K3.

http://www.mobileread.mobi/forums/sh...d.php?t=237799
Reply 

#5  fortyfour 10-30-2014, 11:33 AM
Here is a solution for Kindle paperwhite, hat tip: https://gist.github.com/maxogden/5052838

Code
touch /mnt/us/WIFI_NO_NET_PROBE
restart wifid
Just bumping/sharing on thread because this was one of first threads I found in my search. Cheers!
Reply 

Today's Posts | Search this Thread | Login | Register