Mobileread
KOReader running on BQ/Fnac devices
#1  pazos 10-16-2018, 10:46 AM
KOReader running on BQ/Fnac devices

The following devices are supported by KOReader.
Installation instructions
Usb storage support
Touchscreen info
Wireless info


available sources
bq qt stock reader (QBookApp) https://github.com/bq/cervantes
bq qt e-ink support https://github.com/bq/cervantes-qt/tree/eink-imx508/src/plugins/gfxdrivers/einkfb
bq mx508 hardware abstraction layer https://github.com/bq/cervantes/tree/master/bqHAL
safemode tool https://github.com/pazos/cervantes-safemode
Reply 

#2  pazos 10-16-2018, 10:46 AM
First time Installation instructions

You'll need a sdcard.
  1. Install Developers firmware and enable telnet
  2. Download KOReader dependencies attached in this post
  3. Download KOReader from github
  4. Copy KOReader and dependencies to the sd card
  5. Insert the SD card on your ereader and start a telnet connection.
  6. Uncompress/install KOReader and KOReader dependencies:

    Code
    mv /mnt/sd/ko* /mnt/private
    cd /mnt/private
    tar -xvf ko*.tar.gz
    dpkg -i *.deb
    unzip koreader-cervantes*.zip

Congratulations, You are ready to start KOReader

You can run KOReader from telnet with
Code
/mnt/private/koreader/koreader.sh
. This will stop the stock ereader while KOReader is running and return to it when KOReader exits.

If you are happy with KOReader and want to use it at boot you need to do;
Code
cp /etc/rc.local /etc/rc.local.backup
cp /mnt/private/koreader/koreader-standalone.sh /etc/rc.local
.

Note: ko-deps.tar.gz contains generic prerequisites. ko-deps-safemode-latest.tar.gz contains the latest version of the safemode tool, and is only required if you want to enable USB Mass Storage support under KOReader
[gz] ko-deps.tar.gz (834.5 KB, 332 views)
[gz] ko-deps-safemode-latest.tar.gz (219.5 KB, 164 views)
Reply 

#3  pazos 10-16-2018, 10:55 AM
Touch Protocol

All devices support Single Touch Protocol. The Cervantes 4 (and maybe other recent models) emits both Single Touch and Multitouch B input events. The device reports:

Code
evtest /dev/input/event1
Input driver version is 1.0.1
Input device ID: bus 0x18 vendor 0x0 product 0x0 version 0x0
Input device name: "Neonode zForce touchscreen"
Supported events: Event type 0 (EV_SYN) Event type 1 (EV_KEY) Event code 330 (BTN_TOUCH) Event type 3 (EV_ABS) Event code 0 (ABS_X) Value 619 Min 0 Max 1072 Event code 1 (ABS_Y) Value 832 Min 0 Max 1448 Event code 24 (ABS_PRESSURE) Value 0 Min 0 Max 1048 Event code 47 (ABS_MT_SLOT) Value 0 Min 0 Max 1 Event code 48 (ABS_MT_TOUCH_MAJOR) Value 0 Min 0 Max 255 Event code 49 (ABS_MT_TOUCH_MINOR) Value 0 Min 0 Max 255 Event code 52 (ABS_MT_ORIENTATION) Value 0 Min 0 Max 1 Event code 53 (ABS_MT_POSITION_X) Value 0 Min 0 Max 1072 Event code 54 (ABS_MT_POSITION_Y) Value 0 Min 0 Max 1448 Event code 57 (ABS_MT_TRACKING_ID) Value 0 Min 0 Max 65535
Properties:
Testing ... (interrupt to exit)
A single touch will output:
Code
Event: time 51393.692783, type 3 (EV_ABS), code 57 (ABS_MT_TRACKING_ID), value 1607
Event: time 51393.692786, type 3 (EV_ABS), code 53 (ABS_MT_POSITION_X), value 350
Event: time 51393.692788, type 3 (EV_ABS), code 54 (ABS_MT_POSITION_Y), value 249
Event: time 51393.692789, type 3 (EV_ABS), code 48 (ABS_MT_TOUCH_MAJOR), value 8
Event: time 51393.692790, type 3 (EV_ABS), code 49 (ABS_MT_TOUCH_MINOR), value 8
Event: time 51393.692792, type 3 (EV_ABS), code 0 (ABS_X), value 249
Event: time 51393.692793, type 3 (EV_ABS), code 1 (ABS_Y), value 722
Event: time 51393.692795, type 1 (EV_KEY), code 330 (BTN_TOUCH), value 1
Event: time 51393.692796, type 3 (EV_ABS), code 24 (ABS_PRESSURE), value 1024
Event: time 51393.692797, -------------- SYN_REPORT ------------
Event: time 51393.694611, type 3 (EV_ABS), code 57 (ABS_MT_TRACKING_ID), value -1
Event: time 51393.694615, type 1 (EV_KEY), code 330 (BTN_TOUCH), value 0
Event: time 51393.694616, type 3 (EV_ABS), code 24 (ABS_PRESSURE), value 0
Event: time 51393.694617, -------------- SYN_REPORT ------------
KOReader only supports SingleTouch for these devices
Reply 

#4  pazos 10-18-2018, 03:13 PM
Wireless Support

stock software uses connman to manage wireless connections. KOReader uses wpa_supplicant.

Wireless chipset is always powered.
More info
Reply 

#5  pazos 10-18-2018, 08:52 PM
Unlock

By default the device is locked (no shell access, no external booting, store, adobe drm) and firmware updates need to be signed with BQ private key.

BQ provides instructions to install a Developers edition firmware on https://blog.bq.com/es/bq-ereaders-developers-program/.

You need to install Developers edition firmware to be able to install KOReader or other software. This means you'll lose the nubico store and adobe drm support.
Reply 

#6  pazos 02-15-2019, 07:39 PM
If you installed the last version of safemode tool you will see a new menu entry on KOReader (see first image attached)

If you enter in storage mode you will see the second image. You can now connect the usb cable to your computer and do the changes you want. Once you're done you can extract your usb drive (like you do with any other USB drive on your operative system) and then press the home button to return back to KOReader.

New books will be readily available for you to read!
IMG_0014-1.jpg IMG_0016-3.jpg 
Reply 

#7  pazos 02-16-2019, 04:28 PM
Create a new folder on the usb partition called dict and copy inside the dictionaries you want to install in KOReader (stardict files, do not create subfolders for different dictionaries).

Dictionaries will be moved to KOReader installation when you return back to KOReader.
Reply 

#8  brno 03-14-2020, 02:19 PM
Hi,
I just tried to install koreader on my cervantes 4, using the latest version 2020.03.2.
When I execute the code I get this error :

Code
root@MiWiFi-R3G-srv:/mnt/private# tar -xvf ko*.tar.gz
tar: ko-deps.tar.gz: Not found in archive
tar: Exiting with failure status due to previous errors
Reply 

#9  brno 03-14-2020, 05:05 PM
I managed to solve the problem concerning the tar command, using the following code
Quote
mv /mnt/sd/ko-deps.tar.gz /mnt/private
mv /mnt/sd/ko-deps-safemode-latest.tar.gz /mnt/private
mv /mnt/sd/koreader-cervantes-v2020.03.2.zip /mnt/private
cd /mnt/private
tar -xvf ko-deps.tar.gz
tar -xvf ko-deps-safemode-latest.tar.gz
dpkg -i iproute_20120521-3+b3_armel.deb
dpkg -i iputils-ping_20101006-1+b1_armel.deb
dpkg -i safemode_0.5.0_armel.deb
dpkg -i unzip_6.0-8+deb7u5_armel.deb
dpkg -i safemode_0.6.0_armel.deb
unzip koreader-cervantes-v2020.03.2.zip
But when I execute the command
Quote
root@MiWiFi-R3G-srv:/mnt/private# dpkg -i iproute_20120521-3+b3_armel.deb
Here is the error I get:
Quote
(Reading database ... 11316 files and directories currently installed.)
Unpacking iproute (from iproute_20120521-3+b3_armel.deb) ...
dpkg-deb (subprocess): decompressing archive member: internal gzip read error: '<fd:4>: incorrect data check'
dpkg-deb: error: subprocess <decompress> returned error exit status 2
dpkg: error processing iproute_20120521-3+b3_armel.deb (--install):
cannot copy extracted data for './sbin/rtacct' to '/sbin/rtacct.dpkg-new': unexpected end of file or stream
Errors were encountered while processing:
iproute_20120521-3+b3_armel.deb
By the way, I'm using a PC and I use Putty to connect to the reader via Telnet. And I don't know much about Linux :-)
Reply 

#10  pazos 03-14-2020, 05:11 PM
Quote brno
Hi,
When I execute the code I get this error :

Code
root@MiWiFi-R3G-srv:/mnt/private# tar -xvf ko*.tar.gz
tar: ko-deps.tar.gz: Not found in archive
tar: Exiting with failure status due to previous errors
Shall I proceed to the next lines?
Thanks in advance for your help!
Duh! My fault. When I wrote the instructions for the first time there was only a single attachment. Then I updated the second attachment and modified the instructions to match, but I never actually run the tar command to uncompress both attachments at the same time .

So, what happens is: you have both ko-deps.tar.gz and ko-deps-safemode-latest.tar.gz on /mnt/private and globbing doesn't work as expected and tries to uncompress ko-deps.tar.gz from within the other container. Again, duh!

What you need to do is uncompress both, with:
Code
tar -xvf ko-deps.tar.gz
tar -xvf ko-deps-safemode-latest.tar.gz
And continue with the next lines (dpkg -i to install prerrequisites, unzip to unzip koreader). Hope it helps.

edit: use the exact command for dpkg -i. That should work!. If not do apt-get -f install. That will fix dependencies between packages. If that still doesn't work please check that your deb file is not corrupted. You can download it again or fetch another version as long as is compatible with Debian Wheezy with armel ABI. Prerequisites here are just to make things easier but there should be a few mirrors online for these packages.
Reply 

  Next »  Last »  (1/2)
Today's Posts | Search this Thread | Login | Register