Mobileread
Server locks library ?
#1  howi42 10-18-2020, 02:14 PM
I am running a server on one system. ( 5.3 )
If I am using the client on the same system, everything is fine.
If I shut down that client, leaving the server up and running, I cannot connect to the database by running calibre on another system.
If I shut down the server, too, I can run calibre on another system and connect to the existing databases.

I had never problems before running the server on one system and run calibre on another system.
Reply 

#2  theducks 10-18-2020, 04:44 PM
The 'client' for the server is a browser
If you had Calibre running, IT is the server.
The stand-alone server is run from the CLI (calibre-server.exe <user args> )
IIRC you should not run the GUI with the standalone server running on the same Library
Reply 

#3  howi42 10-18-2020, 06:08 PM
Yes, and maybe.
Running calibre, starting the server and closing the browser window means probably the same
as running the server from cli.
Connecting to the databases used by the server is possible, you can always start the calibre GUI and from there start the server.
But you cannot have two GUI running on the same databases.
That is the design, as far as I understand it.
But now this only works if I open the browser window on the same system.
Reply 

#4  theducks 10-18-2020, 08:36 PM
NO
Closing the GUI window (please do no say Browser. That indicates Firefox, IE...) stops the server. MINIMIZING leave it running.

The GUI and CLI versions are NOT the same. Only one can be in use.
either behaves similar from a Client Browser
(see the Commandline docs for the arguments needed)
Reply 

#5  howi42 10-18-2020, 09:41 PM
Problem has been solved.
Uninstalling and installing calibre again solved it.
But it required some action, as uninstalling leaves a few things untouched.
Cleaning everything manually and doing a fresh installation helped.
Reply 

Today's Posts | Search this Thread | Login | Register