Mobileread
Content Server IP Not Within LAN Range
#1  Agricola 09-07-2020, 08:44 PM
I have two instances of Calibre running; one installed on a Debian Buster desktop that works fine, the other installed on an Openmediavault server that works in the web gui but I am unable to connect with my iPhone app.

The Content server on Openmediavault picks up an IP of 172.21.0.2, while the server has an IP of 192.168.1.101, therefore I am unable to connect my iPhone to. I installed Calibre using docker compose. I have done it several times and I always get the wrong IP address listed for the Content server. Anybody able to show me what I am doing wrong? Here is the compose file I am using:

---
version: "2.1"
services:
calibre:
image: linuxserver/calibre
container_name: calibre
environment:
- PUID=1000
- PGID=100
- TZ=America/Chicago
volumes:
- /srv/dev-disk-by-label-disk1/Calibre:/config
ports:
- 8082:8080 #I have other dockers running on 8080 & 8081
- 8083:8081
restart: unless-stopped
Reply 

#2  kovidgoyal 09-07-2020, 11:55 PM
The server by default listens on 0.0.0.0 which is all IPs. If you want it to listen on a particular IP use the command line option for it.
Reply 

#3  Agricola 09-08-2020, 01:40 PM
Quote kovidgoyal
The server by default listens on 0.0.0.0 which is all IPs. If you want it to listen on a particular IP use the command line option for it.
Thank you. That worked for me, however I had to connect to my server-version of Calibre with my iPhone/MapleReads SE app by using a User-defined entry. It still failed to be Auto-detected, like it does with Calibre installed on my Debian desktop machine. It still gets the job done, although the interface on the User-defined connection is not quite as elegant as the interface on the Auto-detected connection. That, however is not caused by Calibre iteslf. I will have to dig into my phone app, or find another app one better suited to my situation.

Thanks again.
Reply 

#4  HereIAm 10-17-2020, 10:07 PM
Quote
...IP of 172.21.0.2, while the server has an IP of 192.168.1.101...
Since you run Calibre from container, that IP is the internal one of the Calibre VM, and the container already mapped the port 8081 to the host's 8083, so just use 192.168.1.101:8083 to access the Content Server. Ignore what it says on the Calibre's UI.
Reply 

Today's Posts | Search this Thread | Login | Register