Mobileread
New to me IRiver Story HD not connecting to wifi
#1  stageson 07-08-2014, 12:42 PM
Hey all,

I searched and searched yesterday and there doesn't seem to be an answer to my issue except that the device may be faulty. I got this off Ebay from someone who said everything worked. I was looking for a reader that could get my books from Google books. I know I can't browse or purchase books anymore, but not interested in that. Just wanted to be able to access my Google Books on an I-Ink device. So I got this. It says it is on 1.29 firmware. It will "see" the wifi try to connect, then I get the message that there was a problem connecting to the internet, then a slash through the wifi icon in the top right corner. I thought maybe it was a security/password issue, so I've tried it on multiple wifi connections both secure and unsecure. I've tried to find another downloadable firmware file...maybe downgrading will get it to work.

Just so you know I am tech savy. I have rooted several android devices and such. I have also tried to download the files from the iriver site and they always come out as being corrupt. I know I can always just load books to it manually, but it sort of defeats the purpose for me getting this device. Any help would be appreciated.

Scott
Reply 

#2  frostschutz 07-08-2014, 06:37 PM
Be careful with the firmware. It bricks easily (and no one has provided an unbrick method yet!), even with the files from iriver. My recommendation is to only update it through the wifi updater, which is of course a problem in your case.

As long as it sees the wifi (shows you a list of available networks w/o asking you to enter anything besides the password), that at least means that wifi must be working to some degree; so at least you weren't sold a basic Story HD Basic that has no Wifi at all.

Encryption should not be a problem (wpapsk2 in my case).

You could open the device (4 screws, 2 in the SD slot and 2 hidden under glued-on rubber feet and see if the antenna is connected properly. There is a "story hd teardown" video on YouTube which shows what it's supposed to look like.

Can't speak for Google functionality - never used it.

Quote
I have rooted several android devices and such.
Well, I've rooted the Story HD (and bricked one in the process), you can find some simple mods here, but none help with wifi issues. Without wifi you can make it run sh scripts as root on startup. However debugging wifi issues this way will be a bit... futile? I don't know.

Some background info used to be here but that site is apparently in the process of dying:

http://morgue.openinkpot.org/wiki/Device/StoryHD
Reply 

#3  stageson 07-09-2014, 11:10 AM
Thanks for the reply. That was what I was afraid of. I will check to make sure it is all connected properly, but other than that, you are not aware of any wifi issues?

Thanks again for the reply.

Scott
Reply 

#4  frostschutz 07-09-2014, 01:18 PM
I'm not aware of wifi issues, no. I have a full firmware update for 1.34 US somewhere and a downgrader for 1.34 to 1.29. Installing those should replace / reset the firmware, so if you believe it is a software modification problem, that might help; but I can't guarantee/vouch for the quality of those files.
Reply 

#5  stageson 07-14-2014, 01:21 PM
I don't know if the firmware upgrade would do it either. It still works of course as a reader, just won't connect to the internet. I would try to upload new firmware but as I said before I can't get a clean download from the IRiver website. Every time it says the file is corrupt.
Reply 

#6  frostschutz 07-14-2014, 06:55 PM
I can't download it either from iriver anymore. Download starts slow then breaks down altogether. Gets a few more megs by keeping resuming, until it stops returning data whatsoever. So I guess they died completely.

Here's a full firmware file for 1.34 US but I can't vouch for it in any way it might brick your reader use at your own risk:

ptth//:de.metamorpher/files/storyeb07-mod-iriver-1.34-us-2013-05-11-May.zip

If that works you can go back to 1.29 US afterwards (since 1.34 removed the browser and all) using my Downgrade mod which is also in this forum. Although to actually use the browser you'd also have to install my Webportal mod I guess. Oh well.

Never tested Google books. Dunno if it would work.
Reply 

#7  stageson 07-17-2014, 02:24 PM
Thanks. I'm not even to google books yet. It won't even connect to internet.

I will give it a go.
Reply 

#8  stageson 07-17-2014, 02:27 PM
Was that meant to be a link to a file? Something's not right in the syntax of the link.
Reply 

#9  frostschutz 07-18-2014, 05:03 PM
It's an IQ test. :P
Reply 

#10  stageson 07-21-2014, 11:51 AM
Well I have the first part figured out of course... but any other hints?
Reply 

  Next »  Last »  (1/2)
Today's Posts | Search this Thread | Login | Register