Mobileread
Calibre 4.3 - Tag Browser Opens on Start
#11  mbovenka 11-21-2019, 11:00 AM
My tag browser also suddenly kept opening on startup after having used it once. It stopped doing it after I played around with my settings, but I have no idea what I did to make that happen.

About the weird startup time in the debug log: it does that here too. It seems like it only ends the 'startup' when you quit Calibre.
Reply 

#12  theducks 11-21-2019, 11:25 AM
Quote kovidgoyal
No it is seconds, not milliseconds, run it for yourself and check.

That does not answer why he had that huge number, but says 3 seconds

( I wish I got those kinds of numbers 23 Seconds on an old Dell is still not bad)
Reply 

#13  gbm 11-21-2019, 11:55 AM
Put an SSD in it, you can get a new DATARAM 240gb for around $30 on ebay, check on Amazon also.

bernie
Quote theducks
That does not answer why he had that huge number, but says 3 seconds

( I wish I got those kinds of numbers 23 Seconds on an old Dell is still not bad)
Reply 

#14  theducks 11-21-2019, 01:28 PM
Quote gbm
Put an SSD in it, you can get a new DATARAM 240gb for around $30 on ebay, check on Amazon also.

bernie

There is some other recent (windows Video) issues with this beast.

Gobs of RAM, and a 10K RPM drive and it has always been a slightly slow Calibre start.
Reply 

#15  Sirtel 11-21-2019, 02:38 PM
Mine starts in 16 seconds. And that's on a relatively new PC with 16 GB RAM and a SSD. But then, my library is huge, I have lots of custom columns including composites, a ton of plugins and a few color/icon rules. I expect all those play their part. When I tried with a small library of 1600 books, I got the starting time down to 5 seconds.
Reply 

#16  kovidgoyal 11-21-2019, 08:10 PM
Weird, the only way it could possibly print out the startup time on finish is if the initialize() method never returns. Which would break a whole bunch of other things. Try running with --ignore-plugins and see if that makes a difference.

And these startup numbers seem way off. With a few thousand books calibre startups shouldn't take ore than a couple of seconds on any decent system.
Reply 

#17  mbovenka 11-22-2019, 06:19 AM
Playing around with it some yesterday evening shows that the startup times have gone back to normal; leaving Calibre active for a while and then quitting it no longer gives me a multi-minute 'startup time'. Copying my settings from another Calibre install also fixed the tag browser opening on startup-issue, so it looks like Calibre isn't updating some setting file correctly. I excluded my settings directory from Defender, but that didn't help.

I'll play with it some more this evening.
Reply 

#18  bongorash 11-26-2019, 10:32 AM
I've had a similar problem - changing the layout view option to show the cover browser then changing it back to not showing cover browser wouldn't save, now everytime I start up calibre it opens with the cover browser showing no matter how many times I disable it. Finally sorted it by looking at the gui.json file in the calibre preferences folder (I'm on macos) and manually editing this file so that the lines:

cover_browser_splitter_horizontal_state": [
true,
and
cover_browser_splitter_vertical_state": [
true,
are changed to false.

For some reason this file doesn't appear to be updating these changes automatically.. Perhaps @Kovidgoyal could look at this ?
Reply 

#19  kovidgoyal 11-26-2019, 10:43 AM
I cant get it to do that, so hard for me to debug.
Reply 

#20  mbovenka 11-26-2019, 01:38 PM
Here the tag browser keeps opening. Starting Windows in safe mode doesn't help. The debug log only shows an issue with the Find Duplicates plugin (which works fine regardless):

Spoiler Warning below






calibre Debug log
calibre 4.4 [64bit] embedded-python: True is64bit: True
Windows-10-10.0.18362-SP0 Windows ('64bit', 'WindowsPE')
('Windows', '10', '10.0.18362')
Python 2.7.16+
Windows: ('10', '10.0.18362', 'SP0', u'Multiprocessor Free')
Interface language: None
Successfully initialized third party plugins: DeDRM (6, 6, 2) && KoboTouchExtended (3, 1, 5) && Count Pages (1, 9, 0) && Quality Check (1, 9, 11) && Extract ISBN (1, 4, 4) && Goodreads (1, 4, 0) && KePub Input (3, 0, 0) && KePub Metadata Reader (3, 0, 2) && Webscription (1, 1, 0) && Obok DeDRM (6, 5, 4) && Fantastic Fiction Adults (1, 1, 0) && Manage Series (1, 2, 8) && Barnes & Noble (1, 2, 15) && KePub Metadata Writer (3, 0, 3) && catawiki (0, 0, 2) && KindleUnpack - The Plugin (0, 81, 5) && Fantastic Fiction (1, 3, 0) && Kobo Utilities (2, 9, 0) && BOL_NL (3, 8, 25) && KePub Output (3, 1, 3) && Find Duplicates (1, 6, 4)
calibre 4.4 [64bit] embedded-python: True is64bit: True
Windows-10-10.0.18362-SP0 Windows ('64bit', 'WindowsPE')
('Windows', '10', '10.0.18362')
Python 2.7.16+
Windows: ('10', '10.0.18362', 'SP0', u'Multiprocessor Free')
Interface language: None
Successfully initialized third party plugins: DeDRM (6, 6, 2) && KoboTouchExtended (3, 1, 5) && Count Pages (1, 9, 0) && Quality Check (1, 9, 11) && Extract ISBN (1, 4, 4) && Goodreads (1, 4, 0) && KePub Input (3, 0, 0) && KePub Metadata Reader (3, 0, 2) && Webscription (1, 1, 0) && Obok DeDRM (6, 5, 4) && Fantastic Fiction Adults (1, 1, 0) && Manage Series (1, 2, 8) && Barnes & Noble (1, 2, 15) && KePub Metadata Writer (3, 0, 3) && catawiki (0, 0, 2) && KindleUnpack - The Plugin (0, 81, 5) && Fantastic Fiction (1, 3, 0) && Kobo Utilities (2, 9, 0) && BOL_NL (3, 8, 25) && KePub Output (3, 1, 3) && Find Duplicates (1, 6, 4)
Turning on automatic hidpi scaling
devicePixelRatio: 1.0
logicalDpi: 120.0 x 120.0
physicalDpi: 127.664921466 x 127.590697674
Using calibre Qt style: True
[0.00] Starting up...
[0.02] Showing splash screen...
[0.42] splash screen shown
[0.42] Initializing db...
[30.69] db initialized
[30.70] Constructing main UI...
DEBUG: 0.0 obok::utilities.py - loading translations
DEBUG: 0.0 obok::dialogs.py - loading translations
DEBUG: 0.0 obok::config.py - loading translations
DEBUG: 0.0 obok::action_err.py - loading translations
DEBUG: 0.0 KoboUtilites::action.py - loading translations
DEBUG: 0.0 KoboUtilites::dialogs.py - loading translations
DEBUG: 0.0 KoboUtilites::action.py - loading translations
DEBUG: 43.0 No Kobo Touch, Glo or Mini appears to be connected
DEBUG: 43.0 rebuild_menus - self.supports_ratings=None, self.supports_tiles=None
DEBUG: 43.0 KoboUtilities:set_toolbar_button_tooltip - start: text='None'
DEBUG: 43.0 KoboUtilities:set_toolbar_button_tooltip - setting to text='Utilities to use with Kobo ereaders

Driver: KoboTouchExtended'
Traceback (most recent call last):
File "site-packages\calibre\gui2\ui.py", line 412, in initialize
File "calibre_plugins.find_duplicates.action", line 56, in initialization_complete
AttributeError: 'Main' object has no attribute 'clear_button'
[75.84] main UI initialized...
[75.84] Hiding splash screen
SMART_DEV ( 0.00: 0.001) _attach_to_port try ip address "" on port 9090
SMART_DEV ( 0.99: 0.833) _startup_on_demand listening on port 9090
SMART_DEV ( 1.05: 0.000) _attach_to_port try ip address "" on port 54982
SMART_DEV ( 1.11: 0.000) _startup_on_demand broadcast socket listening on port 54982
[81.58] splash screen hidden
[81.58] Started up in 81.58 seconds with 324332 books
SMART_DEV ( 2.24: 1.073) run All IP addresses {u'{85164C06-C78D-11E7-A876-806E6F6E6963}': [{'broadcast': u'127.255.255.255', 'netmask': u'255.0.0.0', 'addr': u'127.0.0.1'}], u'{C01DB1E2-5444-42B2-9091-21F897BCA924}': [{'broadcast': u'192.168.192.255', 'netmask': u'255.255.255.0', 'addr': u'192.168.192.5'}]}
Reply 

 « First  « Prev Next »  Last »  (2/3)
Today's Posts | Search this Thread | Login | Register