Mobileread
Calibre Companion not find Moon+ reader - why?
#1  Maslo 12-29-2013, 12:46 PM
Hi, thankyou for a very good solution for my reading experience.

I first installed CC on my phone, and the books opens without any problem. (Moon+ Reader pro 2,3,2)

Later on my Acer Iconia tablet. Everything worked out good, without one thing:

When i press on "READ" or a book in Calibre Companion after downloaded books it says:
"Do you have a reader app? You need to have a reader app installed to be albe to read a book. There are many good free reader apps on Google Play. Some examples are Moon+ and FBReader.
If you think you already have a reader app installed, please see our FAQ"


I have searched the FAQ and the forum for information about how to solve this, but without finding the answer.

Moon+ is working, and i have imported the books to the shelf there, but it would be nice to also be able to open them from CC.

Thanks for every idea around this.
Reply 

#2  chaley 12-29-2013, 05:48 PM
What kind of ebook format (epub, mobi, etc) are you using? What happens when you attempt to read a book from a file manager?
Reply 

#3  Maslo 12-30-2013, 07:36 PM
Hi, thankyou. I tried as you suggested to open it from a file manager. Then it comes the message "No applications found for this filetype".

Then i installed Mantano e-reader, and then when i press "READ" in CC it asked if i wanted to download the book or read it.

So it seems like it's something with Moon+

I uninstalled both of them, but then I received the message that i need to have a reader app to be able to read a book.

In the phone (where it works to press "READ"), I have in the phone /sdcard/Books a folder MoonReader and beside there is one file metadata.db and metadata_db_prefs_backup.json

On the tablet its the same, folder but the two metadata files are not there. It must be me that have deleted them. Can this be the reason it not working. Can i copy them from the phone and into the tablet again. Or is it some another way to fix it?
Thankful for every input possible.

I of course could use Mantano reader, but I so much like Moon+ than I would like to fix this.
Reply 

#4  Maslo 12-30-2013, 07:47 PM
I now copyied "metadata.db" and "metadata_db_prefs_backup.json" from the phone to the tablet in case the missing files was the reason. But it not helped.

So as i understand It's something else missing? Something that is not "coming back" when i uninstall and reinstall Moon+

Something that makes the tablet not wanting to associate the Moon+ with the epub's.
Reply 

#5  chaley 12-31-2013, 07:29 AM
The files metadata.db and metadata_db_prefs_backup.json should not be on your tablet. They are the calibre database files.

I have no idea why Moon+ is not installing on your tablet so that it "advertises" what kind of books it can read. I use Moon+ pro on all my devices (Nexux 7, HTC Sensation, Galaxy Nexus, Galaxy Tab 10.1) and it works perfectly. The only thing I can suggest is the "nuclear" option: reset the device to factory settings and start over.
Reply 

#6  Maslo 12-31-2013, 11:02 AM
Yes, I will try that.
If it's not working out I at least have one more argument to myself for to buy that new Nexus 7 I have been looking at...
Wish You a Happy New Year and thanks a lot for help and I'm sure I will enjoy CC and Moon+ a for my reading experience a lot next year.
Reply 

Today's Posts | Search this Thread | Login | Register