Mobileread
testplugin_v015.zip
#11  KevinH 03-13-2016, 04:40 PM
Updated the first post to testplugin_v012.zip to work with the forthcoming Sigil 0.9.4 release that includes a Nav by default under epub3.

KevinH
Reply 

#12  patrik 04-03-2016, 08:27 AM
Would it be useful to have the testplugin check for python3-tk?

I just ran a couple of plugins for the first time, and they all failed due to not finding the module _tkinter.
Which was easily solved by installing python3-tk.

The plugins are optional, and the testplugin checks the basic installation, but maybe it could save some time for some users?
Reply 

#13  DiapDealer 04-03-2016, 08:46 AM
Quote patrik
Would it be useful to have the testplugin check for python3-tk?

I just ran a couple of plugins for the first time, and they all failed due to not finding the module _tkinter.
Which was easily solved by installing python3-tk.

The plugins are optional, and the testplugin checks the basic installation, but maybe it could save some time for some users?
The linux build instructions specifically mention python3-tk as one of the minimum requirements in the "Getting Python 3.4" section. But we'll certainly take it under advisement.
Reply 

#14  darkbreath 04-20-2016, 12:55 AM
I tried the plugin test and it failed. Can anyone help me interpret the errors? This was on an Ubuntu computer:

Status: failed

Verify sys.path settings manually
/usr/local/share/sigil/plugin_launchers/python
/usr/lib/python3.4
/usr/lib/python3.4/plat-x86_64-linux-gnu
/usr/lib/python3.4/lib-dynload
/usr/local/lib/python3.4/dist-packages
/usr/lib/python3/dist-packages
/home/kingmidas/.local/share/sigil-ebook/sigil/plugins/testplugin

Verifying proper Python packages are available
Python Package: PIL Found
Python Package: cssselect Found
Python Package: cssutils Found
Python Package: html5lib Found
Python Package: lxml Found
Python Package: regex Found
Python Package: chardet Found
Python Package: six Found

Verifying Sigil Python Libraries can be found/loaded
Sigil Python library: epub_utils Found
Sigil Python library: quickparser Found
Sigil Python library: compatibility_utils Found
Sigil Python library: sigil_bs4 Found

Verifying Hunspell Spell Checking
Hunspell en_US affix file and dictionary Missing
Hunspell shared library Missing
Hunspell spellchecking works False

Verifying Sigil Gumbo Library operation
Sigil Gumbo BS4 Adapter library Traceback (most recent call last):
File "/usr/local/share/sigil/plugin_launchers/python/launcher.py", line 135, in launch
self.exitcode = target_script.run(container)
File "/home/kingmidas/.local/share/sigil-ebook/sigil/plugins/testplugin/plugin.py", line 182, in run
import sigil_gumbo_bs4_adapter as gumbo_bs4
File "/usr/local/share/sigil/plugin_launchers/python/sigil_gumbo_bs4_adapter.py", line 35, in <module>
import sigil_gumboc as gumboc
File "/usr/local/share/sigil/plugin_launchers/python/sigil_gumboc.py", line 161, in <module>
SourcePosition.EMPTY = SourcePosition.in_dll(_dll, 'kGumboEmptySourcePosition')
ValueError: /usr/bin/python3: undefined symbol: kGumboEmptySourcePosition
Error: /usr/bin/python3: undefined symbol: kGumboEmptySourcePosition
Reply 

#15  eschwartz 04-20-2016, 01:09 AM
Not sure what the deal is with the gumboc error, but the hunspell error implies you a) don't have a recognized en_US hunspell dictionary, and b) do not have libhunspell.so which is supposed to be a stable symlink to libhunspell-1.3.so.${sover}
Reply 

#16  DiapDealer 04-20-2016, 09:16 AM
@darkbreath: would probably have to see what cmake options you used to build Sigil (I'm assuming it's at least been built from source since the 0.9.5 tag). Are you overriding any settings with environment variables when launching Sigil? Unless you specifed the -DUSE_SYSTEM_LIBS=1 option with cmake, Sigil should have built hunspell from its own sources (and would automatically be available unless you modified the files after installation).

The gumboc error is quite baffling. Does Sigil function normally otherwise? Is the spellchecker working to highlight misspelled words in Code View?
Reply 

#17  darkbreath 04-20-2016, 03:46 PM
Hi there. Maybe some background information will help. I just want to say I am not a programmer and therefore had significant difficulty compiling Sigil from source, which I unfortunately had to do with Linux. To be quite honest, I was surprised Sigil compiled at all. I would appreciate any help correcting compilation mistakes I may have made.

I used this page as my general guide: https://github.com/Sigil-Ebook/Sigil/blob/master/docs/BuildingOnLinux.md

I managed to get through every section except "Advanced Stuff."

However, I deviated on several occasions when I had to:

1. When installing Pillow, I got some error. I googled the error, and found a page that suggested these commands:

sudo apt-get build-dep python-imaging
sudo apt-get install libjpeg8 libjpeg62-dev libfreetype6 libfreetype6-dev

I installed those dependencies and it worked again.

2. I'm on Ubuntu 14.04. The version of cmake in official repositories is only about 2.8. I compiled and installed the latest version of cmake myself from cmake.org. I believe I have version 3.52. I followed cmake's readme instructions.

3. I was confused as to which python packages to install (3 or 3.4), so I installed BOTH when both were options. I am uncertain if this led to any problems. The packages this could have applied to are as follows:

python3
python3-dev
libpython3
libpython3-dev
python3-pip
python3-tk
python3-lxml
python3-six

I surmise this may have led to the wrong version of python being used during the plugin test?

4. I see -DUSE_SYSTEM_LIBS under "Advanced Stuff" in the Github guide I followed. If this is what you meant, I didn't touch it; I was only at the "Testing Sigil's Python plugin framework" section when I discovered those errors and posted for help.

Unfortunately I haven't tried the spell checker; I didn't think Sigil would work properly unless the errors were resolved.

As for the cmake command, the one I used was similar to the one in the guide but corrected for location of Qt:

cmake -G "Unix Makefiles" -DCMAKE_PREFIX_PATH=/opt/Qt5.4.2/5.4/gcc_64/lib/cmake -DCMAKE_BUILD_TYPE=Release ../sigil-src

I'm not sure if this made a difference, but I used Qt 5.5.1 (64-bit version).

Please help! I'm in over my head. If someone could just make a ppa for Linux it'd be great. Having to compile from source was like climbing a mountain with both feet tied together. Painful. But since I've gotten this far and Sigil is important for my work, I'll do what I have to do to fix it.
Reply 

#18  Doitsu 04-20-2016, 04:04 PM
@darkbreath: Since the error was most likely caused by the hunspell library, have you tried to install the hunspell package and a hunspell dictionary, e.g. hunspell-en-us?
Also install the FlightCrew plugin (or any other plugin written by KevinH/DiapDealer) and test it.
If it works fine, you can most likely ignore the testplugin error messages unless you plan to use a spellcheck plugin.
Reply 

#19  eschwartz 04-20-2016, 04:09 PM
Well, building software on Ubuntu is fun.

I don't really know what packages etc. you need for that. I do know that Sigil is available in the Debian unstable repositories (but not yet in the current Debian release).
Give it a few years and Ubuntu might ship it too.

Arch Linux has had it since forever. And I maintain the sigil-git package for the Arch User Repository.

...

I've looked once or twice at how to package a Debian/Ubuntu package (for calibre), but couldn't really figure it out.
Maybe I could copy the version in Debian and turn it into a PPA. I hear they've got git dailybuild recipes now, and everything...
Reply 

#20  DiapDealer 04-20-2016, 09:51 PM
If you're not trying to use system libs, then no hunspell packages should need to be manually installed. They're included with Sigil (including the necessary dictionaries).

What's the gcc version on 14.04? Anything short of gcc 4.8 is probably asking for trouble with Sigil's C++11 requirements.

In addition to that--lets start simple. If the plugin framework can't find/use the hunspell library/dictionaries, lets make sure they're where they're supposed to be. It looks like you went with the default install prefix of /usr/local, so the libhunspell.so shared library should be located in /usr/local/lib/sigil directory (along with the libsigilgumbo.so file and the sigil binary).

The hunspell dictionaries should be in the /usr/local/share/sigil/hunspell_dictionaries directory (a bunch of .dic and .aff files).
Reply 

 « First  « Prev Next »  Last »  (2/3)
Today's Posts | Search this Thread | Login | Register