Mobileread
Error when reading config file in Linux
#1  dator 07-28-2018, 10:16 AM
Hello,

I am having trouble with running Calibre server on VPS. I copied existing library from my local PC to home folder on VPS.

When I try to start server with command

Code
calibre-server --with-library ~/doom/Library
I get error

Code
No write acces to /home/doom/.config/calibre using a temporary dir instead
Traceback (most recent call last): File "site.py", line 75, in main File "site-packages/calibre/srv/standalone.py", line 13, in <module> File "site-packages/calibre/db/legacy.py", line 18, in <module> File "site-packages/calibre/db/backend.py", line 34, in <module> File "site-packages/calibre/utils/img.py", line 18, in <module>
ImportError: libGL.so.1: cannot open shared object file: No such file or directory
Is there something I am missing?
Reply 

#2  gbm 07-28-2018, 11:21 AM
What version of calibre?

Also give calibre Read/Write privileges for /doom/Library.
bernie
Quote dator
Hello,

I am having trouble with running Calibre server on VPS. I copied existing library from my local PC to home folder on VPS.

When I try to start server with command

Code
calibre-server --with-library ~/doom/Library
I get error

Code
No write acces to /home/doom/.config/calibre using a temporary dir instead
Traceback (most recent call last): File "site.py", line 75, in main File "site-packages/calibre/srv/standalone.py", line 13, in <module> File "site-packages/calibre/db/legacy.py", line 18, in <module> File "site-packages/calibre/db/backend.py", line 34, in <module> File "site-packages/calibre/utils/img.py", line 18, in <module>
ImportError: libGL.so.1: cannot open shared object file: No such file or directory
Is there something I am missing?
Reply 

#3  dator 07-28-2018, 11:40 AM
Changing permissions worked. Thank you for that.

Now I am facing new problem. After issuing command as in my first post I get

Code
Usage: calibre-server [options] [path to library folder...]
Start the calibre Content server. The calibre Content server exposes your
calibre libraries over the internet. You can specify the path to the library
folders as arguments to calibre-server. If you do not specify any paths, all the
libraries that the main calibre program knows about will be used.
Whenever you pass arguments to calibre-server that have spaces in them, enclose the arguments in quotation marks. For example: "/some path/with spaces"
Running

Code
calibre-server /home/doom/Library
results in

Code
calibre server listening on 0.0.0.0:8080
OPDS feeds advertised via BonJour at: 54.xx.xx.xxx port: 8080
and no access to library.

I forgot to add I use latest version of Calibre as of today
Reply 

#4  gbm 07-28-2018, 01:03 PM
With the latest calibre you do not need to pass the library argument. Just use
Code
calibre-server
When you login to calibre via web browser you should see this:
show attachment »
Just click on the library you wish to see.

bernie
Quote dator
Changing permissions worked. Thank you for that.

Now I am facing new problem. After issuing command as in my first post I get

Code
Usage: calibre-server [options] [path to library folder...]
Start the calibre Content server. The calibre Content server exposes your
calibre libraries over the internet. You can specify the path to the library
folders as arguments to calibre-server. If you do not specify any paths, all the
libraries that the main calibre program knows about will be used.
Whenever you pass arguments to calibre-server that have spaces in them, enclose the arguments in quotation marks. For example: "/some path/with spaces"
Running

Code
calibre-server /home/doom/Library
results in

Code
calibre server listening on 0.0.0.0:8080
OPDS feeds advertised via BonJour at: 54.xx.xx.xxx port: 8080
and no access to library.

I forgot to add I use latest version of Calibre as of today
Reply 

#5  DNSB 07-29-2018, 12:17 AM
Quote dator
Code
calibre-server /home/doom/Library
results in

Code
calibre server listening on 0.0.0.0:8080
OPDS feeds advertised via BonJour at: 54.xx.xx.xxx port: 8080
and no access to library.

I forgot to add I use latest version of Calibre as of today
Hmmm... why is your calibre-server listening on IP address 0.0.0.0 is the first question that pops to mind.
Reply 

#6  darryl 07-29-2018, 12:34 AM
What do you mean when you say "no access to calibre library". Is this a message you get in your browser. What address are you trying to access? (Don't post the full address please).
Reply 

#7  dator 07-29-2018, 06:09 PM
Quote DNSB
Hmmm... why is your calibre-server listening on IP address 0.0.0.0 is the first question that pops to mind.
I didn't make any sens to me in first place. It's what terminal spitted out when I issued command as in my first post. Eventually I decided to start all over again and follow this tutorial

Code
https://www.mobileread.com/forums/showthread.php?t=288408
and this command was the key in the right direction

Code
sudo calibre-server --userdb /home/myuser/.config/calibre/server-users.sqlite --manage-users
I can run server without any issues so far. It will need some fine tuning only.

Thank you for your help.
Reply 

Today's Posts | Search this Thread | Login | Register