Bebook can't see my ebooks.
#1  rube 01-06-2018, 12:35 AM
I've bought a second hand Bebook. It's the original Bebook afaik, it's from 2008. It worked at first but then:

Turn on the Bebook and it cycles through the brand name screen and to the next screen which only has "Recent files" folder on it. Pressing the number for Recent files brings up an empty screen.

Plug the ereader back into the computer while it's switched on and it brings up the message to press ok to connect, pressed ok, open windows explorer and the ereader is visible.

Click on the USB Drive (in this case the F in windows explorer and it shows nothing on the right side of windows explorer.

Right click and look at properties and find 122 MB used space.

I have used the reset button (a couple of times) but no change.

I have tried to copy an ebook onto the ereader and it wanted a folder created for it, didn't want me to save it to root.

Tried to create a folder and it brought up this error:

"An unexpected error is keeping your from creating this folder. If you continue to receive this error you can use the error code to search for help with this problem.

Error 0x8000FFF: Catastrophic failure"

Tried to research this error but there's so much, it's so broad and so general. It seems it can happen under sooo many circumstances. I did try unplugging the device, disabling the anti virus program, turning the Bebook back on, plugging it in to the computer again. the same empty drive in windows explorer and the same message when I tried to create the folder, and the same used space on the Bebook.

I've searched through these forums and thought downloading the firmware might be a solution, that it would rebuilt the system, but all the links I could find are broken and I haven't had any luck finding a working link on the net.

Any ideas? It's not going to break my heart if it's dead, I only pain $20 for it, but I like playing with gadgets and seeing if I can resucitate this one would please me a lot.

Do you need any more information?

Thanks in advance.

#2  BobC 01-07-2018, 06:15 AM
First of all the BeBook is not dead; if it were you wouldn't get the (empty) Recent Files screen nor be able to connect via USB.

Fortunately the Bebook is device which had a lot of tinkerers when it was current and there are quite a few different firmwares which were brewed for it, including the manufacturer's own, Lbook (Ukraine), Astek, Paparye and others.

I'd be inclined to dig into these and retrieve an image that you could load onto the BeBook, your biggest problem would be finding a SD card that is compatible with the firmware update - ideally an old 512Mb is what you want, bigger cards can present problems.

I have two of these devices, one is running Hanlin's firmware, the other Openinkpot. Stay away from Openinkpot as you can't easily connect to it via USB.

If you get really stuck finding a firmware image online PM me and I'll dig into my archives and see if I have anything suitable.

There is a host of info in this forum about firmware but you need to trawl through some quite old posts to find it.


#3  JSWolf 01-07-2018, 06:24 AM
Have you tried the BeBook with Calibre?

#4  rube 01-08-2018, 02:54 AM
Calibre can't see them either but thanks JSWolf, I hadn't thought of trying Calibre. BobC I'll start searching for suggested firmware and get back to you

#5  BobC 01-08-2018, 04:31 AM

It's worth checking out the Hanlin forum as well , BeBook was a re-badged Hanlin device.


#6  JSWolf 01-08-2018, 07:01 AM
Quote rube
Calibre can't see them either but thanks JSWolf, I hadn't thought of trying Calibre. BobC I'll start searching for suggested firmware and get back to you
Remove all the eBooks from your BeBook and add them again with Calibre and see how it goes. Try eBooks without DRM.

The eBooks you are having trouble with, do they have DRM?

#7  BobC 01-08-2018, 10:48 AM
Are you sure that the "F" drive on the PC refers to the main BeBook memory and not the SD slot ?

Have you tried checking on the BeBook that your display refers to the Internal Storage rather than the SD Card ? (Menu, then does item 5 show "Built-in Storage" or "SD Card" ?

Have you tried putting a SD card in the BeBook slot and sticking some books on it (say in a folder called "Books") You could put the books on the card directly with your PC before inserting the card.

Once you have a SD card mounted your PC should show another drive that refers to the card.

To me it sounds like the internal user storage memory has become corrupted. This memory is exposed to USB via a bit of Linux software called "Mass Storage Gadget". Installing fresh firmware should sort this out unless the actual memory chip is damaged.

Another thought - have you set the time/date on the BeBook ? I don't think it should matter but always worth a check.


#8  BobC 01-11-2018, 12:47 PM

I have PMd you a couple of links to firmware that will work on the BeBook, most of the original stuff has disappeared from the web.


#9  BobC 01-11-2018, 03:34 PM
**** Duplicate Message******

#10  rube 01-12-2018, 09:06 PM
After a couple of delays I'm back on this now.

JSWolf Calibre can't see the books at all let alone remove them. And it was all the books and none had DRM.

BobC there isn't an SD card in the reader but I think I've tracked down a suitable card so I'm going to test putting some books on it and see if they can ben seen. I'll also try out the files you sent me links to and let you know how I go

  Next »  Last »  (1/2)
Today's Posts | Search this Thread | Login | Register