Mobileread
Claibre cannot connect with CC
#1  clairebarri 07-28-2013, 07:33 PM
Hello All,

Up until Calibre v.9.39 I was able to connect with Calibre with no trouble at all, I am now on 9.41. When examining the IP addresses I found that the last digit was a .5 on my computer and a .6 on the tablet (I had no problems connecting to the net using the wi-fi). I tried the common suggestions which say I should use the fixed port 9090 and then edit my IP address on CC. All that happened was an error message informing me of an incorrect IP address and how I should use the default. I then changed the IP address on the tablet itself to match the one on my computer by selecting the "static" mode. With both the individually inputted IP and port info with the static mode all that happens is that CC becomes stuck on the "connecting" stage and goes no further.

I don't know that much about techy issues, so I'm a bit stumped. I've re-booted both the tablet and the computer with no luck. I hope someone can assist me in this as it is quite frustrating.

Thanks!
Claire
Reply 

#2  theducks 07-28-2013, 08:56 PM
Welcome to MR

Just connected via calibre companion to Calibre using my 7" Tab2
I am using 9.41 [newdb]

I do not specify IPor port for wireless connection in Calibre Companion

I do have the content server connection set for both Internal and WAN IP
Reply 

#3  chaley 07-29-2013, 02:33 AM
Quote clairebarri
Hello All,

Up until Calibre v.9.39 I was able to connect with Calibre with no trouble at all, I am now on 9.41. When examining the IP addresses I found that the last digit was a .5 on my computer and a .6 on the tablet (I had no problems connecting to the net using the wi-fi). I tried the common suggestions which say I should use the fixed port 9090 and then edit my IP address on CC. All that happened was an error message informing me of an incorrect IP address and how I should use the default. I then changed the IP address on the tablet itself to match the one on my computer by selecting the "static" mode. With both the individually inputted IP and port info with the static mode all that happens is that CC becomes stuck on the "connecting" stage and goes no further.

I don't know that much about techy issues, so I'm a bit stumped. I've re-booted both the tablet and the computer with no luck. I hope someone can assist me in this as it is quite frustrating.

Thanks!
Claire
It is hard to know what changed to break things. My guess is that the IP address of your desktop changed, but I have no evidence for that other than intuition.

I suggest that you do the following:

1) In CC, use Settings/Wireless Device Connection to switch the connection type to the default (tap the Use Defaults) button.
2) In calibre, ensure that the wireless device settinds/use a fixed port is unchecked.
3) In calibre, ensure that the wireless device is enabled (Connect/Share).

This returns CC and calibre to their respective defaults. Try to connect. If it works, then good.

If it doesn't work, then:
1) Check your firewall. In 99% of cases this is the problem. You didn't say what kind of computer you are using for calibre, so I can't go any further here.
2) Start at the beginning of this FAQ answer and do all the steps in order.

If at the end of this you cannot connect, post a debug log here as described in this FAQ answer.
Reply 

Today's Posts | Search this Thread | Login | Register