Mobileread
Battery indicator in M92
#1  Quix0te 05-05-2012, 04:47 AM
Hello! I've got my M92 three days ago from ereader-store.de. After a short test I've decided to charge the battery to its full capacity first since this seems to prolong its life (at least this is what I've heard about Li-Ion batteries). Initial level was 43%. First, I've tried to charge from PC, then using the power adapter, with the reader being on and off, but the outcome was always the same: the charge level dropped or remained unchanged, although both LED and battery icon indicated that charging is in progress. I've successfully updated the FW to the improved version 1.6 20120105 but the indicator behaviour didn't change. The longest charge time I tried was about 8 hours.
Has anybody encountered this problem? Any ideas, please?
The actual battery level is 21% and I want to see what happens when it reaches zero: if this is just an indicator problem it will continue working. Otherwise I'll have to return it which is a pity: the device is amazing.
Thank you.
Reply 

#2  Dulin's Books 05-05-2012, 10:51 AM
it takes a charge cycle or two for the meter to read the battery correctly.
Reply 

Today's Posts | Search this Thread | Login | Register