PocketBook 611 internal SD card image, help to recover
#1  lukyp 01-26-2023, 06:27 AM
Hello guys,

I would be very pleased if somebody could send me an internal SD card image for PocketBook 611.

I got an old PocketBook 611 from electric trash, but without internal SD card, it looks like it is fully functional (does not have big scratches), I just had to replace a battery (because its battery was about 3 cm thick )

I have followed this guide (translated over google translator).
I'm able to boot a firmware update dialog (central button + forward button), put SWUPDATE.BIN onto 4-th fat32 partition. Device reports that firmware update was successful and device will now restart. After restart it:
- left side of the main button lights on
- both sides of the main button lights on
- screen flash for a half a second
- screen is empty

When I power a device to power supply (or PC), it is showing a battery charging dialog and both sides of main button are blinking.
When connected to PC, it is not able to identify a USB device

/dev/sdb is an internal device SD card:

My partitions
Device Boot Start End Sectors Size Id Type
/dev/sdb1 32768 1081343 1048576 512M 83 Linux
/dev/sdb2 1081344 2129919 1048576 512M 83 Linux
/dev/sdb3 2129920 3178495 1048576 512M 83 Linux
/dev/sdb4 3178496 4227071 1048576 512M 83 Linux
Created filesystems
mkfs.ext2 /dev/sdb1
mkfs.ext2 /dev/sdb2
mkfs.ext2 /dev/sdb3
mkdosfs -F 32 -I /dev/sdb4
copied firmware file(SWUPDATE.BIN) to /dev/sdb4

Boot up a firmware update dialog and installed firmware SUCCESFULLY.

But after restart of device, it is showing just empty screen (as mentioned earlier).

When I check partitions after installation I found they are shrink to minimal size, sdb1 has free about 1MB and sdb2 has free 0 bytes !!!

I found on 0x200 there is something like:
SN-E6063222M06597 8_1111101246 which can be device serial number + something.

Is it kind of hash of SD card id and device id.

I have tried multiple firmware versions, firmware was able to identify serial ID of a device other firmwares reported device id as 00000000000000000 (with a message, cannot read a device id)

There is something about serial ids, it is for a different type of device, it generated 4 bytes long file .freezestatus

I do not have a serial cable to connect a device using UART to PC to have an access to boot log.

Could you please help me with that?
Thank you,

#2  lukyp 01-26-2023, 09:38 AM

What I have tried:
I have extracted application which I guess is responsible for that

firmware 15.8
nm -D|grep -i serial
0000fa68 T get_serial_num
0000e9ec T ioc_getserialnumber
firmware 16.0
nm -D|grep -i serial
00014fcc T get_serial_num
00013bc8 T ioc_getserialnumber
0002b9f4 B serialnum
strings |grep -i serial
Serial Number:
Serial number: %s
monitor: cannot locate serial number
But, there is no word freezestatus in a whole image (stored as a plain text, maybe it is encrypted, or it is not using in a this device at all).


Generated file .freezestatus
./serial --serial_number SN-E6063222M06597 --sd_serial 0x058F63666433
and this version too:
./serial --serial_number E6063222M06597 --sd_serial 0x058F63666433
then copied this file to /dev/sdb3 and /dev/sdb4

Tried to write this into offset 0x200:
echo -en "SN-E606321AF12297\08_1111101246\0"|dd bs=1 seek=512 conv=notrunc of=/dev/sdb
But still does not work.

This thread is about replacing of hardware SD card serial id with a known one (which come from original SD card). But I do not have original SD card, so this is not helpful for me too.

In that thread it is mentioned:
Changing that will result in constant bootloop.
But in my case, there is no bootloop, there is just a blank screen or charging battery screen (when attached to charger).

I was able to run other application (snake):
I replaced symlink of pocketbook to
ln -sf bin/ pocketbook
And application was running !!!
Clock worked too:
ln -sf bin/ pocketbook
But issue is that does not work

Do you have an idea how to continue, what else I can try? Run it in qemu and debug it?
Maybe try to get from this device

Do you think that from TL3/626 would work on PocketBook 611?

Today's Posts | Search this Thread | Login | Register