iLiad can't charge iLiad battery
#1  ragdoll 04-19-2011, 03:40 AM
I have an iLiad V1 since the beginning of 2008. I didn't use it for some months and yesterday I couldn't turn it on. I thought the battery needed recharging, but when I connected the charger, the red light on the upper left corner didn't turn on.
I then tried to turn on the device and it worked, this time also the charging led lit. However, as soon as I disconnected the charger, the iLiad turned off.
I think the battery is dead, am I right?
What can I do?

#2  Shaggy 04-19-2011, 11:41 AM
Sounds like a dead battery.

There's a thread on here somewhere that gives instructions for replacing the battery. I'll add a link if I can find it, otherwise hunt through the older topics and you should come across it eventually.

Here's a link

#3  anttdk 11-11-2015, 06:49 AM
I had same issue.
I replaced 2 batteries with NOKIA BL-5C ( did not had time to order for bigger capacity / use what found at home + total battery capacity 2010 mAh (2x 1050mAh) will be enough, as original total 1000 mAh.
And now it is working
Yee ))

Today's Posts | Search this Thread | Login | Register