Anybody found solution to Goodreads integration failure?
#1  kyteflyer 04-29-2018, 05:57 PM
I have emailed Kris but no response thus far: hopefully he will reply this week sometime (its only been a few days)

I was wondering if anyone has found a way round the failure to integrate? I can be logged in to GR in its app, or on the web, but when I try to link from Marvin3, the page is blank, so no capacity to accept in the GR site. Thats on the iPhone. Oddly, no issues on the iPad at all.


#2  Zebedi 04-30-2018, 12:45 AM
I have had the same issues on an iPad for some time, so a fix would be good.

#3  nimapourkarimi 05-09-2018, 08:52 AM
Remove the goodreads app and let marvin open safari when you try to link it to goodreads, that should do it.

#4  kyteflyer 05-10-2018, 08:51 PM
Thanks, I'll give that a go, since Kris has not bothered responding to my query (now 2 weeks since I wrote) which surprised me, he used to be very responsive.

[edit] and that works, thank you so much.

#5  nimapourkarimi 05-11-2018, 04:22 AM
You’re welcome. I think the problem is a fault on goodreads side, not marvin’s.

#6  kyteflyer 05-12-2018, 02:15 AM
Seems like thats the case, otherwise your solution would not have worked.

#7  antproof 01-28-2019, 09:58 PM
I’m late to the party but thanks for the Goodreads fix. I just got a new iPad and it was driving me crazy thst I couldn’t connect to GR.

Sent from my iPad using Tapatalk

#8  Ferante1 05-21-2020, 08:50 PM
Starts to open goodreads, then asks - Open in Marvin? If I click Cancel, stops loading Goodreads and loads another page of my Safari history (?) I deleted my entire Safari history, so now I forced it to go to the goodreads page. But it does nothing there, except I see a message on Goodreads sayong "This app is already authorized". But then I go back to Marvin, and GR shows still as unlinked. Tried same many times. Can anyone help?

Today's Posts | Search this Thread | Login | Register