Mobileread
Unable to start calibre server
#1  dator 08-17-2018, 09:10 AM
There is open thread to enable HTTPS on calibre server and I didn't want to spam it so I decided open this one.

I created self signed SSL certificate and when i try to start calibre server I get this error

Code
xxxxx@xxxxxx:~$ sudo systemctl status calibre.service
● calibre.service - Calibre Service Loaded: error (Reason: Invalid argument) Active: inactive (dead)
Aug 17 13:43:25 xxxxxx systemd[1]: Stopped Calibre Service.
Aug 17 13:43:44 xxxxxx systemd[1]: [/lib/systemd/system/calibre.service:12] Missing '='.
This happens when I add this two lines to calibre.service file

Code
--ssl-certfile /etc/apache2/ssl/apache.crt \
--ssl-keyfile /etc/apache2/ssl/apache.key \
Reply 

#2  jlosito 08-18-2018, 09:30 AM
Can you post the rest of your service file?
Reply 

#3  dator 08-19-2018, 07:55 AM
Sure.


Code
[Unit]
Description=Calibre Service
After=network.target
[Service]
Type=simple
User=xxxxxx
Group=xxxxxx
ExecStart=/usr/bin/calibre-server\
--max-opds-items=30\
--max-opds-ungrouped-items=100\
--port 8282 \
--log=/home/xxxxxx/calibre.log \
--enable-auth \
"/home/xxxxxx/xxxxxx"
--ssl-certfile /etc/apache2/ssl/apache_test.crt \
--ssl-keyfile /etc/apache2/ssl/apache_test.key \
[Install]
WantedBy=multi-user.target
Reply 

#4  kovidgoyal 08-20-2018, 01:12 AM
You execstart directive is wrong. THe two lines need to be added to the rest of the options, not a tht end by themselves.
Reply 

#5  dator 08-20-2018, 05:09 PM
Quote kovidgoyal
You execstart directive is wrong. THe two lines need to be added to the rest of the options, not a tht end by themselves.
Many thanks. This worked like charm.

One more question. When I connect to my library, web browser reports

Code
https://library_ip_adress/port_number certificate does not have valid HTTPS certificate. This maybe caused by...
and so on. This is normal for self signed certificate?
Reply 

#6  gbm 08-20-2018, 05:31 PM
Quote dator
Code
https://library_ip_adress/port_number certificate does not have valid HTTPS certificate. This maybe caused by...
and so on. This is normal for self signed certificate?
Yes, you will need to manually add and exception to the browser.

bernie
Reply 

#7  dator 08-21-2018, 02:01 PM
Quote gbm
Yes, you will need to manually add and exception to the browser.

bernie
Would it be too much to ask how to do it?
Reply 

#8  gbm 08-21-2018, 03:14 PM
Quote dator
Would it be too much to ask how to do it?
Each browser is different, different versions of the same browsers are different. Just have to look it up in the help.

For example FireFox 61. You will have to follow he links.

Will led you to this page See Self-signed certificate.

bernie
Reply 

#9  Marx 08-29-2018, 04:53 AM
Or use letsencrypt certificate, it's free and authority signed
Reply 

#10  jlosito 08-31-2018, 09:45 AM
Quote Marx
Or use letsencrypt certificate, it's free and authority signed
That's what I did. It's really easy to set up using the certbot cli tool, and I can verify that after setup you won't get that warning for the latest version of Firefox on Fedora 28. I used the standalone option because I don't have a proxy properly set up yet.
Reply 

Today's Posts | Search this Thread | Login | Register