Mobileread
New KoReader update doesn't work in my device.
#1  the_doc 03-15-2016, 06:19 PM
Hi, I have been using this KoReader version "koreader-kobo-arm-linux-gnueabihf-v2015.11-106-gd9b55af" until today without problems.
Today I have tried several times to update to the last version "koreader-kobo-arm-linux-gnueabihf-v2015.11-253-gcf9dc26". First I tried with the OTA service, and later manually, connecting the device to the computer.
When I try to start Kobo pushing in its icon I see the KO Reader logo for a couple of seconds and then the device restarts.
If I install the previous version KoReader works again.
I have a Kobo Mini with firmware 3.17.3 and I use fmon to start KoReader. I have PBChess in my Kobo and it starts well with fmon.
Any advice?

EDIT: Solved in version 2015.11-330.
Reply 

#2  JSWolf 03-15-2016, 06:28 PM
Maybe try the latest 3.19 version firmware.
Reply 

#3  the_doc 03-15-2016, 06:39 PM
Yes, I could try that or I could try to start KoReader with KSM 07 or 08, but that is not the question.
The last koreader update should work with any of the last Kobo firmwares and with fmonitor without problems.
What I want to know is if I can make koreader starts editing some configuration file or if this problem is a bug that can be solved by the developpers.
Reply 

#4  NiLuJe 03-15-2016, 09:31 PM
Known issue (I renamed a variable that KSM checked to detect if KOReader is recent enough for, err, something? . Since I don't use KSM, and the change semeed harmless enough, it slipped through both my tests and code review).

This'll be fixed in the next nightlies, my bad .

EDIT: Fixed packages should be up (>= v2015.11-261).
Reply 

#5  Ken Maltby 03-15-2016, 10:26 PM
Not sure that issue relates to fmon not working to launch KOReader. There is other code there that checks and deals with if Nickel was running. Perhaps some of that was effected?
Reply 

#6  NiLuJe 03-16-2016, 12:29 AM
Whee, I somehow skipped the first post and missed the fmon mention. Yay me.

AFAIK, for all intents and purposes, running it through fmon basically equates to what I'm doing manually over SSH, so, that shouldn't have impacted anything.
Reply 

#7  djalma 03-16-2016, 12:57 AM
I don't know if it's related, probably not :P , but anyway jftr, I previously tested koreader (stable 2015 if I don't remember bad) & fmon, with a random 2MB-3MB epub file and everytime I tried loading it, it frozen the device. I checked the same epub using KSM08 and it worked well. On the other hand, I feel koreader launched with KSM more "light"-"quick" than when I used it with fmon (feels heavier).
Regards.
Reply 

#8  the_doc 03-16-2016, 05:31 AM
At djalma. Nope, it is not related. I don't have configurated my KoReader to start with the last open book. It starts (when it works) with the explorer of archives.
At NiLuJe. I'll check the new version when it is available.
Fmonitor works with KoReader version 2015.11-106 (and previous versions) and it works with PBChess.
Reply 

#9  the_doc 03-25-2016, 09:29 AM
I have tried last development version today (version 2015.11-276 of March 23, 2016).
It doesn't start either. I updated from the computer through USB without success. After that I installed again version 2015.11-106 (this version works) and updated from KoReader with OTA wifi and version 276 didn't work either.
Thinking that maybe something in my configuration of KoReader was the problem I deleted the KoReader directory in my Kobo and I made a clean installation of last development version. KoReader still doesn't start.
Some change introduced by the developpers after version 106 has broken compatibility with fmon, Kobo Mini and firmware 3.17-3.
Back to version 106 that works.
Reply 

#10  JSWolf 03-26-2016, 08:14 PM
So why not try the latest 3.19 firmware and see if fmon/KOread works?
Reply 

  Next »  Last »  (1/2)
Today's Posts | Search this Thread | Login | Register