Mobileread
Exceptional internal memory state Formatting - workaround
#1  gingerbeardman 05-05-2018, 04:41 PM
I get this form time to time.

After the Reader powers up, it does the busy spinner and then says

Code
+---------------------------------------+
| Exceptional internal memory state |
| Formatting |
| [ OK ] |
+---------------------------------------+
At this point pressing OK will format the device.

Workaround
1. press the reset button
2. reader is now off, but screen will remain showing error
3. plug in to computer
4. wait for READER partition to appear

Next steps
Once you see Reader, you can:
1. backup
2. delete any strange files (see below)
3. unplug Reader and everything will be back to normal

Cause
I believe this is cause by unrecognised files being present on the READER partition. For me these are either hidden files created when using macOS to copy files manually over to the READER partition, or files left over from a Calibre sync. I now use an app that cleans the READER partition as it is ejected.
Reply 

#2  Ghitulescu 05-11-2018, 04:34 AM
I cannot stress enough to use the drag'n'drop simple procedure.
One selects the epubs files he wants to transfer, select the drive (internal or SD), sit back and relax. The Sony does it all by itself to its own customs.
Reply 

#3  Ghitulescu 05-11-2018, 04:35 AM
Ah, and it's a good idea to use the SD for unreliably tested or dubious epubs.
Reply 

#4  gingerbeardman 06-26-2018, 03:06 PM
Just got this again, and figured out a way to avoid resetting.

(see below for revised steps)
Reply 

#5  gingerbeardman 07-10-2020, 08:42 AM
Just had this again, but it in the intervening years I had figured out a workaround for the "Exceptional internal memory state. Formatting."

0. Do NOT press OK on the format warning
1. Plug device into the computer
2. Backup READER partition
3. Press RESET button
4. Wait for Reader to reboot (no PRS+ features when booting with USB connected)
5. Unplug from computer
6. Shutdown/restart reader (PRS+ features will be re-enabled)
7. Problem is gone!

My theory is that PRS+ doesn't the device being "dirty" when it is unmounted or ejected improperly.
Reply 

Today's Posts | Search this Thread | Login | Register