The Nook app now works on the Likebook Mars
#1  fduniho 06-02-2020, 12:32 PM
Ever since I got my Likebook Mars in 2018, the Nook app has not worked well with it. Just in case it was only my device, I checked with others online, and no one reported back that the Nook app worked on the Likebook Mars. At best, it would work with an older version of the app that would crash when trying to look up words in the dictionary. But it is now working with the latest version of the Nook app, and looking up words in the dictionary is working well. After highlighting a word, I have to press the A-Z button with a book above it to get the definition. It also provides options for looking up the word in Google or Wikipedia. When I click on the Google button, it complains about not being able to use the browser, but when I click on the Wikipedia button, it lets me open Wikipedia in my browser. So, it's not really making sense that the Google button is not working for the reason given. If anyone knows how to correct that, it would help.

Now that the Nook app works, the Likebook Mars can run the ereading app from every major ereader manufacturer in the west, these being Kindle, Kobo, and Nook. It can also handle Google Play Books. With support for all these apps, I can buy books through any of these apps, though I'm still inclined to favor those with the best features. One of the most important of these is font support. The Kindle, Nook, and Google Play apps all provide a good selection of fonts, but the Kobo app does not. For DRM-free books, the best font support is provided by apps like Moon+ Reader and Librera, which support custom fonts and better customization of font size.

#2  Lparsons21 06-22-2020, 04:17 PM
Just found out that it now works with the latest version. This was my biggest peeve with the Mars.

Today's Posts | Search this Thread | Login | Register