Mobileread
Search and replace in 0.2.0
#1  paulpeer 03-03-2010, 01:31 AM
Is there a way to search (or search and replace) something in the whole book, not just in one chapter?
Reply 

#2  Guns4Hire 03-03-2010, 01:49 AM
I don't think you can do a find or replace within the whole eBook as of yet. I tried to find where Valloric posted that. But couldn't. But I know I read it lol.
Reply 

#3  paulpeer 03-03-2010, 02:33 AM
Quote Guns4Hire
I tried to find where Valloric posted that. But couldn't. But I know I read it lol.
I had the idea, that Valloric posted somewhere that you can do a general search and replace, but I can't find it. If you can't do so, I'll definitely will have to use version 0.1 together with 0.2 ...
Reply 

#4  Bert 03-03-2010, 04:50 AM
From the 0.2.0 beta announcement (emphasis mine):
Quote
Why a beta and not a Release Candidate as I’ve previously announced? Well because not all the features that I want in the 0.2.0 release are done. The biggest omission is the cross-file search: in the current beta, you can only search (and replace) in the currently open tab, but not across all the files in the book.
So it isn't working in the current beta, but it will be implemented later.
Reply 

#5  paulpeer 03-03-2010, 12:18 PM
Quote Bert
From the 0.2.0 beta announcement (emphasis mine):


So it isn't working in the current beta, but it will be implemented later.
Thx Bert for helping me find the announcement!
Reply 

#6  Guns4Hire 03-03-2010, 03:25 PM
Yeah thanks Bert. I knew I had read it as well but couldn't find it. Knew I wasn't losing my mind.
Reply 

#7  Logseman 03-13-2010, 11:48 AM
I have a side issue with search and replace. I've been formatting a German text with 0.2.0 in order to get rid of the "ae", "oe" and "ue" substituting for umlauts. The process runs flawlessly and I can see the changes being made in the text, but for some reason, once I close the menu dialog, the changes are reverted and I see the "ae"s again. Is it a glitch, or am I doing something wrong?
Reply 

#8  Valloric 03-13-2010, 11:59 AM
Quote Logseman
I have a side issue with search and replace. I've been formatting a German text with 0.2.0 in order to get rid of the "ae", "oe" and "ue" substituting for umlauts. The process runs flawlessly and I can see the changes being made in the text, but for some reason, once I close the menu dialog, the changes are reverted and I see the "ae"s again. Is it a glitch, or am I doing something wrong?
Probably a glitch. S&R is unreliable in the current beta, a complete overhaul is scheduled for the next one.
Reply 

Today's Posts | Search this Thread | Login | Register