Mobileread
PRS-T1 Questions about repartitioning
#41  seabee 10-15-2012, 06:57 PM
Quote simongee
YES! GOT IT!
...
1) made backup with rupor's method (tool: Roadkil's Disk Image)
2) connected to pc in recovery mode
3) Used MiniTool Partition Wizard Home Edition 7.6.1 (from here: http://www.partitionwizard.com/free-partition-manager.html), pressing Apply button after EACH modification.
4) shrink READER partition (keep it at the end of the drive, creating free space between READER and /system)
5) move /system to the end of extended partition. Now there is free space between /data and /system)
6) tool cant enlarge /data to the beginning of /system, which is what i wanted to do. So i deleted /data and created new ext4 partition in the space that is now free. Labeled it "data". Then FORMATED it as "ext4"
7) Now /data is empty. I tried to reboot...
... and that's it , worked on first try without a glitch (still have the physical disk full backup just in case), thank you for the reference to MiniTool Partition Wizard, made that repartitioning a breeze under Windows 7, really minimal operations. Just slightly simplified your directives to reflect what I really did, because I didn't had any bad surprise, reader restarted with initial configuration on reboot and that's it. Perhaps because I applied changes step-by-step ?
to you, uboot, rupor and porkupan
Reply 

#42  Nabuccoo 10-25-2012, 05:52 PM
I am here again. Thanks for the answers. I didn't have time in the last few weeks to play with my little T1, so I just read books on it. But the problem is still there for me. I can't see any partitions when I am connecting the reader in recovery mode via usb. So I can't reformat the data partiton, too. I don' understand why... I saw them at the first time when I did this repartitioning.
Reply 

#43  bartch 11-03-2012, 09:19 PM
Hi all,
I have the same problem.
I followed the guide form #41 (applied all the steps separately in Minitool), but it didn't boot at the end, so i used some of #20 tips to recover again..
My PRST1 boots but only has around 38 free memory in /data.
So, i want to format this partition again, but now comes the problem...i can't see my partitions anymore when i connect with Minitool in recoverymode.
I can see the partitions via Putty, but NOT via Minitool or any other Windows-tool.
I managed to get a screenshot from my partition Table and as you can see, there are some errors: Partition 1, 2, 3 and 4 don't end on cylinder boundary.
Maybe this prevents Minitool or Windows to see the partitions in recovery mode?

image »

Can somebody please help me with some tips. I am not a die hard Linux guy, but not afraid to use the terminal. But my knowledge about repartitioning or reparing partitions from within Putty or the command-line is not good enough.
I tried to repartition via the http://wiki.mobileread.com/wiki/PRST...itioning_Guide , but some commands, like (fdisk) p don't work in Putty, and i have no idea how to do it.

Thanks in advance,
Grt,
Bart
Reply 

#44  uboot 11-04-2012, 09:38 AM
you can ignore the cyl boundary warning.

please do not touch partitions mmcblk2p1, mmcblk2p2, mmcblk2p3, or your reader me become irreversibly bricked.

if you apply sd recovery, your data partition will be flashed with 48mb filesystem, such that the file system has 48mb regardless of the actual partition size...

in order to solve this, you may simply reformat the data partition.

in recovery console, this can be done via

Code
mkfs.ext4 -L data -m 0 -j /dev/mmcblk2p9

missing minitool access may be repaired by re-flashing the enableadb package...
Reply 

#45  bartch 11-04-2012, 11:35 AM
thanks Uboot.
Somehow the format command worked finally! Before it didn't.
Do I have to format the system-partition also to ext4? (in the repartitioning tutorial with acronis Disk Director, you mention to format the system also to ext4.

I tried al lots of things, so, i am afraid i had to rebuild reader, system and data from scratch..

In Acronis Disk Director i can also make ext3 partitions.
What do you recommend?

grtz,
Bart
Reply 

#46  bartch 11-04-2012, 05:44 PM
Hi uboot, i got some progress finally. I have put back my image with original partitions and started over again, but this time with Acronis Disk Director Home (ADDH). It looks like Minitool does some bad things..i don't trust it anymore.
Every step of ADDH goes ok, but beware: The translated version of this tutorial in English contains al lot of bad code. The command lines synax gets screwed up by google.translate! So, for the right code, you have to see the Russian code.

Uboot, i am stuck on the last commands.
According to the tutorial ADDH i have to do this after the repartitioning:
#cd /tmp
#mkdir sys (i get the message it already exists!)
#mkdir sd (i get the message it already exists!)
#mount /dev/mmcblk2p4 sd (i get an error: mounting /dev/mmcblk2p4 on sd failed: Input/output error)
#mount /dev/mmcblk2p10 sys (works ok!)
cd sys
tar -xvf /tmp/sd/system.tar . (can't open '/tmp/sd/system.tar': No such file or directory)
cd /tmp

Do you have any idea what's going on?

Grtz
Bart
Reply 

#47  uboot 11-05-2012, 08:42 AM
I have no clue where the commands you cited come from Please give us some link!

Anyways - your reader partition seems to be corrupted. I guess you just have to format it via
Code
mkdosfs -n READER -F 32 /dev/mmcblk2p4
to make it accessible again.

BUT: the commands you listed aim to restore the system partition from a tar file on the reader parition - which won't be there now, so you just ran into a dead end.

I highly recommend you not to blindly enter some commands you find somewhere on the internet, not knowing what exactly they are aiming for.
Reply 

#48  bartch 11-06-2012, 06:07 AM
Hi uboot. Thx for the help. I realize my explanation of what i did was not complete and confusing..but you saved my efforts with your help! Thx

First i tried this tutorial, using Minitool to repartition my PRS-T1, but somehow it got corrupted. So, i restored my original image with RoadKill Diskimage and started all over again, but now with this tutorial:
http://translate.google.com/translate?sl=ru&tl=en&js=n&prev=_t&hl=en&ie=UTF-8&layout=2&eotf=1&u=http%3A%2F%2Fwww.the-ebook.org%2Fforum%2Fviewtopic.php%3Fp%3D917896%239 17896
In this tutorial they use Acronis Disk Director Home (ADDH).
One of the first commands in this tutorial is indeed to make a tar from the system partition, but I couldn't restore it in the end.
So, I used rescue_1.04.zip after repartitioning to restore the system and used your command to reformat the data partition (mkfs.ext4 -L data -m 0 -j /dev/mmcblk2p9). But, with this rescue image, i had to choose my language and Region again on every boot, so I used this rescue image instead: sdrescue_1.04_porkupan.7z
Afterwards i used your format command for the data partition again and now everything is fine!

However, you state that your Package 1 "rescue_1.04.zip" creates more inodes, which is handy for rooting the device later. Is it really neccesary to get more inodes?
(Now i've used Package 2 ( sdrescue_1.04_porkupan.7z) which don't make more inodes)
I rooted my PRS-T1 afterward with AMR and Apps2SD and everything is working ok.

Using ADDH for repartitioning is working ok, but you have to reboot your PC after every repartitioning step, so it takes some time, but it does the job really well.

My other problem, that i couldn't see my PRS-t1 drive with Minitool or Acronis Disk Director is solved. I forgot to put the rupor-rescue.7z image on my external SD-card to boot in recovery mode. If you boot in recoverymode with this image on the SD-card, you are able to see your PRS-T1 drive on your pc and make and restore images from it.

So, everything is working ok now, i have lots of extra storage to put my programs on.

Again, thanks for the help!
Greetings
Bart
Reply 

 « First  « Prev   (5/5)
Today's Posts | Search this Thread | Login | Register