how did Calibre library become read-only?
#1  ChipAHoy 02-08-2018, 10:17 PM
I am not sure how this happened, but when I try to edit some of my entries within Calibre, I get a read-only message. How can I change this setting?

Also, how do I reset the location on my computer that Calibre looks in for my ebook files?

#2  kovidgoyal 02-08-2018, 10:23 PM
It would help if you posted the detailed error, but typically this is caused by either filesystem problems or anti-virus programs that decide to block access.

#3  ChipAHoy 02-09-2018, 03:08 PM
what kind of file system error might it be?
Screen Shot 2018-02-09 at 12.06.33 PM.png 

#4  kacir 02-09-2018, 03:39 PM
Quote ChipAHoy
what kind of file system error might it be?
What system are you on?
Try opening the Calibre Library directory with a file manager and try to create a folder (directory) and create a file inside that folder (directory).
As long as Calibre isn't running at that moment nothing bad should happen.

Calibre complains that the filesystem is read only, so have a look whether it is true.

#5  BetterRed 02-09-2018, 05:25 PM
@ChipAhoy - looks like something on your system is either, changing the file attributes of the metadata.db file in the library folder, or changing its permission settings or those of its parent folder. I've no idea what that might be. Pretty sure it wouldn't be calibre though. Probably the OS itself, or 3rd party security software. Which version/editions of Windows are you using?

You could use File Properties to examine the file attributes and permissions (Security tab) of the metadata.db file, that might give you some clues.


#6  kovidgoyal 02-09-2018, 08:49 PM
That's most likely an antivirus blocking calibre. Because of the way anti-virus programs work, those errors present as read only errors.

#7  CRussel 02-14-2018, 06:39 PM
In a windows environment, one can end up with this issue on a clean install with the Calibre folder attached at the root of a drive. (ie, d:\calibre as the database) This is because, by default, Windows makes non-adminstrators have read-only access to the root of the drive, and calibre runs (as it _should_) without elevating privilege.

I ran into this recently when I virtualized the server that was hosting my calibre database, and forgot to reset the permissions. Duh.

Result? A complaint about a corrupted database. Sigh. Once I changed the permissions to give 'users' write permission, all was well.

#8  LadyKate 02-23-2018, 06:09 PM
I am eager to hear if the OP solved the problem.

Today's Posts | Search this Thread | Login | Register