Mobileread
Forma is my kobo forma screen broken(horizontal and vertical line)
#1  joedoe 11-09-2020, 08:06 AM
got strange horizontal line and vertical line on the screen, it doesn't go away even after factory reset, not sure whether the screen is broken or something, did anyone have similar issue?

show attachment »
Reply 

#2  mbovenka 11-09-2020, 10:33 AM
Quote joedoe
got strange horizontal line and vertical line on the screen, it doesn't go away even after factory reset, not sure whether the screen is broken or something, did anyone have similar issue?
I have a similar vertical line in my screen. I can't see in your picture whether it's 'negative' (dark line on a light background, light line on a dark background) as it is with my Forma.

It's probably a screen driver issue. I'm living with it until it gives up the ghost completely.
Reply 

#3  robko 11-09-2020, 08:08 PM
It may be broken, but looks like a controller problem. Is the vertical line completely straight or any curve/jag in it (would indicate broken)? You'll be able to tell when you turn it on and start flipping pages -- if it's broken parts of the screen won't update.
Of course, a controller problem could also be considered broken -- I'd say it's a hardware issue one way or the other.
Reply 

#4  hobnail 11-09-2020, 09:02 PM
If it's under warranty I'd ask them if it can be exchanged.

The typical problem with a vertical line is a fuzzy one on the side by the buttons, caused by some design failure; it goes away if I turn down the brightness.
Reply 

#5  NiLuJe 11-10-2020, 12:47 AM
The Forma uses a flexible plastic TFT, it wouldn't showcase the usual glass cracks shown on earlier... glass TFT when they... crack .

That, on the other hand, could be a badly seated flex cable. Or something worse. So, yeah, if it's under warranty, call CS.

And, no, this has nothing to do with the Forma's famous frontlight sidebar of doom (because, first: duh. And, second, the frontlight is off on the "connected to a computer" screen).
Reply 

#6  joedoe 11-21-2020, 06:26 AM
thanks all for the reply, i think this is definitely a hardware problem, it's not going away no matter what i do with the reset etc.., and now i got 2 vertical lines instead of 1, they are showing as negative line, similar to this one

https://www.mobileread.com/forums/sh...d.php?t=334431
Reply 

Today's Posts | Search this Thread | Login | Register