Mobileread
Is KT4 still shipped with FW 5.11.0?
#1  itisbomb 07-12-2019, 11:41 PM
I’m ready to pull a trigger on a Kindle ereader on Prime Day. But I cannot yet decide whether to go with PW4 or KT4.

The ability to jailbreak the device is quite a decisive decision factor for me. I know that PW4 is now shipped with FW higher than 5.10.1.3 (so no luck on the jailbreak).

I don’t have a clue about FW that KT4 is currently shipped with. Is it still 5.11.0?

If the current KT4 cannot be jailbroken, I might buy PW4. I get an impression that people here at mobileread community seem to work on hacking PW4 more than on KT4. So PW4 might have a higher chance to be jailbroken in the future.

I would appreciate if anyone can shed light on this.
Reply 

#2  ilovejedd 07-15-2019, 02:47 PM
For what it's worth, my last PW4 purchase in May 2019 (Mother's Day deal), the 8GB SO WiFi had 5.10.1.3 while the 32GB SO WiFi still had 5.10.0.2.

I don't know what's shipping now but perhaps you might want to try your luck with the PW4 32GB.

Could also get both and return the non-jailbreakable model(s).
Reply 

#3  itisbomb 07-15-2019, 04:14 PM
@ilovejedd

Reply 

Today's Posts | Search this Thread | Login | Register