Mobileread
Glo HD Glo HD Battery Replacement didnt work
#1  Thargor 07-11-2019, 03:24 PM
Hi,

I ordered one of these for my Glo HD and installed it today:

https://rounded.com/kobo-glo-hd-n437-ku-bk-k-ep-battery-1500mah-pr-285083.html?sl=en

Problem is it seems completely dead, grey screen (not the black "out of power" the Kobo usually displays for a dead battery, which the stock battery I was replacing still shows if I swap it back in).

I suppose these batteries must have been sitting on warehouse shelves for a good 5 years now and are probably completely wrecked at this stage, same thing happened when I tried to order a few batteries to replace the dead one in my ancient OnePlusOne.

Just thought Id ask and see if anybody had any ideas? Ive left it charging now but still no signs of life, the back has got a bit warm though so Ill charge it overnight and see, any other suggestions?
Reply 

#2  ReaLx3m 07-11-2019, 04:02 PM
First and foremost , check the battery with a multimeter before getting to conclusions.
Reply 

#3  frostschutz 07-12-2019, 07:03 AM
power LED don't blink either when powering off/on?

just asking since... it's so easy for those screens to crack :-/ hope that didn't happen
Reply 

#4  Thargor 07-12-2019, 04:42 PM
Okay this is weird:

-I got home from work yesterday afternoon with the new battery, installed it, dead, not just the default black low battery screen, I mean dead, grey screen no text, no reaction to long-press, paperclip in the hole etc.

-Plugged it into charge (stock charger and cable that came with it 3 years ago) and checked at regular intervals with long-press/paperclip etc over the next 5 hours, nothing.

-Fell asleep on the couch with it plugged in (not smart when testing replacement 3rd party batteries I know). Woke up at 2am (plugged in for about 8 hours with no sign of life at this stage) and I just caught the end of the boot-up sequence, then the sleep screen appeared showing 15% power, watched it rise to 18% over the next few minutes so I left it plugged in and went to bed. In the morning it was fully charged and seemed to be working perfectly so I unplugged it.

-By the time Id got ready for work approx 30 minutes later the battery had dropped to 88%, Kobo was asleep for this period. Rebooted it with long press, still 88% on reboot...

-By the time I got home from work 9 hours later the battery had dropped to 77%, strangely after an hour of reading and a couple of hours sleep the battery is on 76% now.

Im a bit baffled to be honest, this is exactly how the 3 year old stock battery is behaving so now Im thinking could it be a software issue? Kobo is fully updated to latest FW.

Or could it be that both batteries are just wrecked seeing as they're both probably 3-5 years old?

Any suggestions on what I can try?

I confess I was that annoyed at work that I stuck in a few low Ebay bids for a few 2017 Kindle Oasis's and I actually managed to grab one for $170 so now thats on the way now aswell. I might just make the switch to that and if anyone here can help me fix the Kobo it will be a good backup to have or Ill gift it to a friend.
Reply 

#5  NiLuJe 07-12-2019, 05:29 PM
Even on perfectly sane batteries, the battery meter on Kobos can be fairly wonky.

You can try the usual "recalibration" trick (basically making sure it goes to 100% -> 0% -> 100% -> 0% or something to that effect).
Reply 

#6  Thargor 07-12-2019, 07:41 PM
Quote NiLuJe
Even on perfectly sane batteries, the battery meter on Kobos can be fairly wonky.

You can try the usual "recalibration" trick (basically making sure it goes to 100% -> 0% -> 100% -> 0% or something to that effect).
Okay Ill try that on the new battery but the old battery was charging to full and discharging fully in a few days, it didnt feel like a wonky battery meter, it felt like it was crashing from 100% down to zero at a fairly linear rate whether it was awake and turning pages or asleep and losing 10% every few hours. Quick first impressions is this one is doing the same thing but Ill give it a couple of cycles and see.
Reply 

#7  NiLuJe 07-12-2019, 07:45 PM
One doesn't exclude the other . One or both of 'em could genuinely have reduced capacity due to age, I'm just saying: don't trust the software battery gauge, and don't necessarily trust an initial full cycle .
Reply 

#8  frostschutz 07-13-2019, 12:29 AM
also disable sync & wifi altogether, those can be battery hogs sometimes, too
Reply 

#9  Thargor 07-13-2019, 03:22 AM
I never use sync and WiFi.

The battery is at 75% this morning, a 1% drop after an hours reading and a night in sleep mode. I suppose I'll just have to put it through its paces for a week before the Oasis arrives then decide if I want to make the switch...
Reply 

#10  Thargor 07-15-2019, 03:16 PM
How would I check for a corrupt epub draining the battery? Ive searched ut all the results for Calibre plugins are years old, whats the current method? My library is in Calibre.
Reply 

  Next »  Last »  (1/3)
Today's Posts | Search this Thread | Login | Register