Mobileread
Problem to access to javascript website
#1  DevAnges 12-05-2019, 02:43 PM
Hello,

I use Calibre server on a linux based single bord computer (Odroid N2)
My Linux version is Ubuntu MATE 18.04.3.
I install calibre using apt install and I get Calibre V3.21

When I try to access to my website (on the same network) and I get the message
Quote
Loading, please wait…
You can also use a simple, non-javascript version of this site: here
So I can only use the mobile version.

I use the last version of Firefox Windows (V71.0).
I try with Google Chrome and on an Android tablet with Firefox (V68.3) and Google Chrome (V78.0), it is the same result.

I try with another server running linux, a x86 based computer, I can install Calibre V4 and it works fine with the same browsers (Pc and Android).

I have already tested with a previous version on a Linux single board computer, I have the same problem.

Can you help me ?
Is Calibre V3.21 too old to have a good Webserver support ?

Thank you.
Reply 

#2  kovidgoyal 12-05-2019, 10:03 PM
Look in the server logs for error messages. And 3.21 is pretty ancient, I dont really remember the state of the server in it.
Reply 

#3  DevAnges 12-08-2019, 02:57 AM
Thank you for your answer.

This version is the one I got using apt install with my Ubuntu mate...
And it seems quite difficult to generate the latest version from the sources...

My log is this one
Quote
192.168.1.10 port-57132 - 08/déc./2019:07:33:43 +0100 "GET /js/export-csv.js HTTP/1.1" 404 123
192.168.1.10 port-57136 - 08/déc./2019:07:33:43 +0100 "GET /acttheme/custom.js HTTP/1.1" 404 123
192.168.1.10 port-57133 - 08/déc./2019:07:33:43 +0100 "GET /js/domoticz.js HTTP/1.1" 404 123
192.168.1.10 port-57135 - 08/déc./2019:07:33:43 +0100 "GET /js/jquery-ui-timepicker-addon.js HTTP/1.1" 404 123
192.168.1.10 port-57137 - 08/déc./2019:07:33:43 +0100 "GET /js/require.js HTTP/1.1" 404 123
192.168.1.10 port-57134 - 08/déc./2019:07:33:43 +0100 "GET /js/domoticzdevices.js HTTP/1.1" 404 123
192.168.1.10 port-57138 - 08/déc./2019:07:33:43 +0100 "GET /acttheme/custom.css HTTP/1.1" 404 123
192.168.1.10 port-57138 - 08/déc./2019:07:33:43 +0100 "GET /images/restart.png HTTP/1.1" 404 123
192.168.1.10 port-57136 - 08/déc./2019:07:33:43 +0100 "GET /images/contact.png HTTP/1.1" 404 123
192.168.1.10 port-57139 - 08/déc./2019:07:33:43 +0100 "GET /images/log.png HTTP/1.1" 404 123
192.168.1.10 port-57141 - 08/déc./2019:07:33:43 +0100 "GET /images/logout.png HTTP/1.1" 404 123
192.168.1.10 port-57141 - 08/déc./2019:07:33:44 +0100 "GET /acttheme/custom.js HTTP/1.1" 404 123
192.168.1.10 port-57141 - 08/déc./2019:07:33:44 +0100 "GET /css/images/img01.jpg HTTP/1.1" 404 123
192.168.1.10 port-57141 - 08/déc./2019:07:33:44 +0100 "GET /images/logo.png HTTP/1.1" 404 123
192.168.1.10 port-57143 - 08/déc./2019:07:33:44 +0100 "GET /favicon.ico HTTP/1.1" 404 123
192.168.1.10 port-57145 - 08/déc./2019:07:33:44 +0100 "GET /json.htm?type=command&param=gettitle HTTP/1.1" 404 123
192.168.1.10 port-57145 - 08/déc./2019:07:33:44 +0100 "GET /app/app.js HTTP/1.1" 404 123
192.168.1.10 port-57147 - 08/déc./2019:07:33:44 +0100 "GET /js/angular-scrollglue.js HTTP/1.1" 404 123
192.168.1.10 port-57148 - 08/déc./2019:07:33:44 +0100 "GET /js/angular-websocket.js HTTP/1.1" 404 123
192.168.1.10 port-57149 - 08/déc./2019:07:33:44 +0100 "GET /js/angular-route.min.js HTTP/1.1" 404 123
192.168.1.10 port-57150 - 08/déc./2019:07:33:44 +0100 "GET /json.htm?type=command&param=getconfig HTTP/1.1" 404 123
192.168.1.10 port-57150 - 08/déc./2019:07:33:44 +0100 "GET /json.htm?type=command&param=getversion HTTP/1.1" 404 123
192.168.1.10 port-57150 - 08/déc./2019:07:33:44 +0100 "GET /json.htm?type=command&param=getauth HTTP/1.1" 404 123
192.168.1.10 port-57150 - 08/déc./2019:07:33:44 +0100 "GET /views/offline.html HTTP/1.1" 404 123
192.168.1.10 port-57150 - 08/déc./2019:07:33:44 +0100 "GET /app/OfflineController.js HTTP/1.1" 404 123
192.168.1.10 port-57150 - 08/déc./2019:07:34:34 +0100 "GET /acttheme/custom.css HTTP/1.1" 404 123
192.168.1.10 port-57150 - 08/déc./2019:07:34:34 +0100 "GET /acttheme/custom.js HTTP/1.1" 404 123
192.168.1.10 port-57150 - 08/déc./2019:07:34:34 +0100 "GET /acttheme/custom.js HTTP/1.1" 404 123
192.168.1.10 port-57150 - 08/déc./2019:07:34:34 +0100 "GET /css/images/img01.jpg HTTP/1.1" 404 123
192.168.1.10 port-57150 - 08/déc./2019:07:34:34 +0100 "GET /json.htm?type=command&param=getconfig HTTP/1.1" 404 123
192.168.1.10 port-57150 - 08/déc./2019:07:34:35 +0100 "GET /json.htm?type=command&param=getversion HTTP/1.1" 404 123
192.168.1.10 port-57150 - 08/déc./2019:07:34:35 +0100 "GET /json.htm?type=command&param=getauth HTTP/1.1" 404 123
192.168.1.10 port-57150 - 08/déc./2019:07:34:35 +0100 "GET /views/offline.html HTTP/1.1" 404 123
192.168.1.10 port-57159 - 08/déc./2019:07:34:35 +0100 "GET /app/OfflineController.js HTTP/1.1" 404 123
192.168.1.10 port-57160 - 08/déc./2019:07:35:29 +0100 "GET / HTTP/1.1" 200 -
192.168.1.10 port-57197 - 08/déc./2019:07:43:28 +0100 "GET / HTTP/1.1" 304 135
Is it necessary to install an updated template for the server ?
Reply 

#4  DevAnges 12-26-2019, 04:18 AM
Hello,

It is very difficult to have all the software installed to succeed in compilation from sources on my linux board (an Odroid n2). So I dismiss this fix.

I try to update the content-server folder from a working version (the V4.6 portable for Windows) and I copy all the files to the linux folder (/usr/share/calibre/content-server) and now it works fine
Reply 

Today's Posts | Search this Thread | Login | Register