Mobileread
Install failed - help please
#1  ezwebby 12-08-2019, 12:55 PM
I tried installing on linux mint 17.3 and it failed. It is so complex that I haven't got the foggiest how to fix this... Can anyone help resolve please.. Here is the output....

Using python executable: /usr/bin/python3
2019-12-09 03:21:36 URL:https://download.calibre-ebook.com/linux-installer.sh [31887/31887] -> "-" [1]
Installing to /opt/calibre
Downloading tarball signature securely...
Will download and install calibre-4.5.0-x86_64.txz
Downloading calibre-4.5.0-x86_64.txz
100% [================================================== ====================]
Downloaded 100397840 bytes
Checking downloaded file integrity...
Extracting files to /opt/calibre ...
Extracting application files...
Traceback (most recent call last):
File "site.py", line 75, in main
File "site-packages/calibre/__init__.py", line 23, in <module>
File "site-packages/calibre/startup.py", line 204, in <module>
File "site-packages/calibre/utils/icu.py", line 30, in <module>
RuntimeError: Failed to load icu with error: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/calibre/lib/libicui18n.so.64)

thanks
PS: I'm an end user, so please write slowly!
Reply 

#2  theducks 12-08-2019, 01:55 PM
Been AGES since I messed with Ubuntu

there are requirements that need to be met (further down on the Calibre Linux download page)
Code
 You must have xdg-utils, wget, xz-utils and python ≥ 2.6 installed on your system before running the installer.
You need GLIBC 2.18 or higher and libstdc++.so.6.0.21 (from gcc 5.4.0) or higher to run calibre
I think the second one is your problem. Launch the Package manager and see if there is that version (or above) available
Reply 

#3  gbm 12-08-2019, 04:26 PM
Quote ezwebby
I tried installing on linux mint 17.3 and it failed. It is so complex that I haven't got the foggiest how to fix this... Can anyone help resolve please.. Here is the output....

Using python executable: /usr/bin/python3
2019-12-09 03:21:36 URL:https://download.calibre-ebook.com/linux-installer.sh [31887/31887] -> "-" [1]
Installing to /opt/calibre
Downloading tarball signature securely...
Will download and install calibre-4.5.0-x86_64.txz
Downloading calibre-4.5.0-x86_64.txz
100% [================================================== ====================]
Downloaded 100397840 bytes
Checking downloaded file integrity...
Extracting files to /opt/calibre ...
Extracting application files...
Traceback (most recent call last):
File "site.py", line 75, in main
File "site-packages/calibre/__init__.py", line 23, in <module>
File "site-packages/calibre/startup.py", line 204, in <module>
File "site-packages/calibre/utils/icu.py", line 30, in <module>
RuntimeError: Failed to load icu with error: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/calibre/lib/libicui18n.so.64)

thanks
PS: I'm an end user, so please write slowly!
Mint 17.3 is no longer maintained--has passed end of life--so my recommendation is to upgrade to at least Mint 18.3.

Or you can go back to calibre 3.48.0.



bernie
Reply 

Today's Posts | Search this Thread | Login | Register