Help! My new BOYUE T62 is dead
#1  anne.jane 07-07-2017, 01:31 PM
I appreciate guys if anyone can help me. I read all the posts and tried many solutions but none solved my problem.

I tried to uprade my Boyue T62 via wi-fi from the menu but at some point the energy was interrupted.

Then I did a hard reset of the eReader because only had a picture of a dead android in the screen.

Currently the system is unusable since I have a big message on the screen telling me that the UI has stopped working.

Every time when I accept the message it appears again. I can't push any other button.

What can I do?


Please any detailed instructions with download links would be much appreciated. I have many windows with links and all of them only complicate what I need specifically for my model.

Thanks a lot!

#2  guest 07-07-2017, 04:54 PM
Maybe not the best solution for you (because it will most likely remove all your data and it will install a rom different from the original) but probably the easiest: find update.img file (the name may be different, but you need the img format) - links should be available somewhere on this forum and flash it from the pc. The instructions for flashing probably also can be found on this forum. Or for example here: The zip contains instructions (you need only step 1) with all necessary files. It also contains .img file but don't use it (it's for a different device).

#3  anne.jane 07-07-2017, 06:19 PM
Thank you.
But I think the new problem is to find how to put BOYUE T62 in recovery mode.
Nothing seems to work.

#4  guest 07-08-2017, 07:56 AM
I don't know why you need the recovery mode. The flashing software (for example RKBatchTool) can put your boyue in the correct mode (if I'm not mistaken it's bootloader not recovery mode). I think boyue T62 also can be put in the bootloader mode by turning it on while holding one of it's buttons (don't know which one).
It's possible that you were able to put the device in the correct mode but the flushing tool can't see it because your pc doesn't have drivers installed. The package from icarus contains necessary drivers. Also I see drivers here: (probably the same ones). And according to "6- How to unbrick your device" from that link you will get the bootloader mode using the Refresh button.

#5  anne.jane 07-08-2017, 05:39 PM
The RKBatchTook doesn't recognize my device when is connected. I read that I should put the device on recovery mode.
I can't see the contents neither on the explorer. (before the problem I always can)
My device turns on but is not recognized. I installed the drivers already but maybe I need new ones.
I don't know what could be the problem.

Today's Posts | Search this Thread | Login | Register