Mobileread
Koreader not launching anymore on my kobo after update!
#1  lori87 01-13-2019, 09:46 PM
I have Kobo Auro H2O Edition 2 reader, I put some new books on it and when I did it updated to device version 4.12.12111


Now when I click the koreader image in books to launch koreader it just launches the image and NOT koreader, I'm so upset because I did NOT want to update my device.

Is it possible to get it working or did they patch it or something so koreader doesnt work anymore?
Reply 

#2  lori87 01-13-2019, 09:58 PM
Nevermind just reinstalled the whole thing from scratch and it worked again, I lost my dictionaries and stuff and images and screensavers but if there was an easier way ot fix plz let me know
Reply 

#3  NiLuJe 01-13-2019, 10:41 PM
A firmware update will wipe KFMon/fmon, which will obviously prevent it from launching stuff until you reinstall said launcher .

That's perfectly normal, and documented.
Reply 

#4  Alan_S 01-14-2019, 03:51 PM
KSM can intercept firmware upgrade and you can choose to do partial update, which saves crucial files from being overwritten, thus keeping KSM.
Reply 

#5  NiLuJe 01-14-2019, 05:12 PM
In KFMon's case, it's a safety precaution more than anything: in the (unlikely) event a FW update would horribly break it, being disabled ensures it won't cause a boot loop.

But, perhaps more interestingly, it also ensures that it won't clash with fmon or KSM (as in, only one of them will ever be active, because the opposite would be potentially very bad).
Reply 

#6  petrovich 05-12-2019, 08:42 PM
Well, I've just got the same problem. Tried fmon reinstall, but it doesn't seem to help(the behavior didn't change). Any ideas what should I check? TIA
Reply 

#7  NiLuJe 05-12-2019, 09:02 PM
fmon has probably been severely hobbled, if not entirely broken, by a behvaior change introduced in FW 4.13.

I worked it around if KFMon, so, make sure you're either using a current KFMon version, or that you're using KSM.
Reply 

Today's Posts | Search this Thread | Login | Register