Mobileread
libprs500 not recognizing device
#1  mollybo 03-16-2008, 09:17 PM
All of a sudden libprs500 doesn't see my Sony 505. The Sony library recognizes it just fine. It will convert books just fine, but also won't save to disk. The program just hangs.

I uninstalled it and reinstalled it, but no change.

Help? It's been working great so far for dozens and dozens of books.
Reply 

#2  kovidgoyal 03-16-2008, 10:16 PM
Run it from a terminal using the command libprs500.exe and post any output you see.
Reply 

#3  mollybo 03-17-2008, 09:13 PM
Quote kovidgoyal
Run it from a terminal using the command libprs500.exe and post any output you see.
Just to clarify, you mean go to command prompt, change to the libprs500 directory and run libprs500.exe, right? (I used to be a computer geek, but I think I shoved it all out of my mind in self-defense. At least no one asks me to fix their computers now.)

I ran llibprs500.exe and just got a command prompt again - no output. I'm looking for something in the command line area, right? It did launch libprs500, of course.

After rebooting yesterday I can now save files to disk, but my 505 still doesn't show. Since I can save to disk at least this is no longer as urgent a problem as it was. I had converted a book I really wanted to read! Still, I am grateful for any help.
Reply 

#4  kovidgoyal 03-17-2008, 10:49 PM
Yeah, you got it right, though you don't need to change to the libprs500 directory.

I'm afraid you're going to have to wait till the next release of libprs500, where I'll add some code to help debug this problem on windows.
Reply 

#5  mollybo 03-18-2008, 06:42 PM
No worries, I really appreciate your time. Your program has increased my enjoyment of my Reader immeasurably.
Reply 

Today's Posts | Search this Thread | Login | Register