Mobileread
Can't access local SD card files
#1  cns1000 09-05-2020, 11:21 PM
Hi

I installed Calibre Companion 5.4.4.19 on my Android tablet (Alcatel 9024O running Android 7.1.1). I also have installed the Windows version (for Windows 7) on my desktop. I have no problem connecting to the Windows computer as content server over wifi. The problem is connecting using the cloud option to my local device, the tablet, using the SD card,

I installed the demo version first. That one easily saw the directories on the SD card and allowed me to view the directories of books. However, I could not open any of them; they were all grayed out and I eventually got a message that the database was corruipt and unreadable. I figured this might be because I was only using the demo version so I bought and installed the full version. This one, however, will not read the SD card at all.

I have tried uninstalling and reinstalling, rebooting the device, clearing the data and cache. I have checked the permissions; it has full storage permission, which I presume is all that it needs. But when I am given the option to choose a path, I see only "\" with the options Up and Back, neither of which does anything.

Any suggestions ?

Thanks
Charles
Reply 

#2  cns1000 09-06-2020, 12:59 PM
To clarify:

At first I made the newbie mistake of specifying a directory that did not actually contain a Calibre database. I have fixed that now. I connected the tablet to the computer running the db via USB and copied the whole database including metadata.db to it. The desktop detects the device and syncs to it. I can also connect the device wirelessly and send files to it as well as accessing the Windows computer from the tablet as a content server.

What I still can't do is access the local database on the SD card from the tablet itself. I still can't see any directory other than "\", though I can see them from the demo CC app.

Any assistance would be really appreciated.

Thanks
Charles
Reply 

#3  PMrev 09-08-2020, 02:20 PM
Quote cns1000
To clarify:

At first I made the newbie mistake of specifying a directory that did not actually contain a Calibre database. I have fixed that now. I connected the tablet to the computer running the db via USB and copied the whole database including metadata.db to it. The desktop detects the device and syncs to it. I can also connect the device wirelessly and send files to it as well as accessing the Windows computer from the tablet as a content server.

What I still can't do is access the local database on the SD card from the tablet itself. I still can't see any directory other than "\", though I can see them from the demo CC app.

Any assistance would be really appreciated.

Thanks
Charles
Hello,

Our dev team is looking into this, will get back to you.

Alex
Reply 

#4  cns1000 09-11-2020, 12:18 PM
Thank you for the reply. Let me know if you need additional information.

I had thought that possibly the issue might be caused by still having the demo version (which did pick up the directories correctly) installed, so I deleted it, but that made no difference.

For now, since they were using a fair amount of space on the SD card, I have deleted the local SD database files, and I am using the sync via wireless push operation for the device. That seems to work with no problems (aside from the occasional random wireless timeout error).

Thanks
Reply 

#5  Aspis 10-11-2020, 11:18 AM
I have the *exact* same issue on an Android 8.0 Device. tried clearing CC data, cache, uninstalling CC, but no resolution to the issue. Having set the grant permissions to the root of the external SD card on CC's the initial (colorful, first run) set-up prompt screens. I have never been able to reinitialize those setting. Even after clearing everything and uninstalling the app. Those scrrens never reappear and their seems to be no place in CC's setting to change those values. Is there any progress on this issue?
Reply 

Today's Posts | Search this Thread | Login | Register