Mobileread
KOreader "No reader engine" on PW1
#1  LittleBiG 12-23-2020, 06:53 AM
The development builds after 2020.12 doesn't work for PW1. It restructures the cache, reload all cover thumbnails, then I get an error message "No reader engine for this file or invalid file" whichever book I want to open. The only solution is downgrade to the latest stable, however, no cover is shown after that.
Reply 

#2  NiLuJe 12-23-2020, 07:54 AM
Try with a nightly, there was a memory alignment issue in the zstd version used in the release, that was hotfixed a few hours later. It *would* unfortunately be fatal on a Kindle, given how the alignment trap is setup there .

(I checked on a K3 a few days ago, and everything behaved as it was supposed to there).
Reply 

#3  LittleBiG 12-23-2020, 09:39 AM
The problem first appeared with nightly 24, and it is the same even now with 30. I have a modern interface with no reader engine it seems.
Reply 

#4  NiLuJe 12-23-2020, 10:29 AM
PW1 is flat, so, more on that later, but 2020.12-27 worked out just fine on a K3, and -30 just fine on a PW2.
Reply 

#5  LittleBiG 12-23-2020, 11:27 AM
Quote NiLuJe
PW1 is flat, so, more on that later, but 2020.12-27 worked out just fine on a K3, and -30 just fine on a PW2.
Thanks, I am looking forward to it. In the meantime I deleted my KOreader instance then copied the latest nightly to my reader. It was all the same :-(
Reply 

#6  NiLuJe 12-23-2020, 11:29 AM
Well, I did find a fun Kindle special bug in the process, but everything's also fine on my end on a PW1 on 5.6.1.1 with -30.

I would have said try a clean install, but apparently you did, so, check the crash.log instead (in koreader/crash.log).
Reply 

#7  LittleBiG 12-23-2020, 11:36 AM
12/23/20-16:32:30 INFO opening file /mnt/us/koreader/crash.log
[!] doShowReader coroutine crashed:
frontend/apps/reader/readerui.lua:226: attempt to call method 'isStub' (a nil value)
stack traceback:
frontend/ui/widget/widget.lua:48: in function 'new'
frontend/apps/reader/readerui.lua:578: in function 'doShowReader'
frontend/apps/reader/readerui.lua:536: in function <frontend/apps/reader/readerui.lua:535>12/23/20-16:32:30 INFO FM loaded plugin SSH at plugins/SSH.koplugin
Reply 

#8  NiLuJe 12-23-2020, 11:44 AM
I'm going to need the full context, not just an excerpt.
Reply 

#9  LittleBiG 12-23-2020, 11:53 AM
I hope it is ok for you renamed to txt and attached.
[txt] crash.txt (33.2 KB, 30 views)
Reply 

#10  NiLuJe 12-23-2020, 12:00 PM
Which FW version is your PW1 running on?
Reply 

  Next »  Last »  (1/3)
Today's Posts | Search this Thread | Login | Register