Mobileread
Help -- new Calibre won't work on my OS
#1  RevSpyder 10-05-2019, 07:39 PM
I saw that there was a new version of Calibre, so I downloaded it. When I went to open it, I got a message that it wouldn't work on my old Mac Mini OS High Sierra 10.13.6

There's no place on the Calibre site where I can see how to download the last version that worked on my OS.

Anyone know what I can do?
Reply 

#2  RevSpyder 10-05-2019, 07:59 PM
Never mind -- a friend figured it out and sent me a link that had a version that worked for me. How he found it, I don't know... But I'm back in business!
Reply 

#3  JSWolf 10-05-2019, 08:07 PM
Quote RevSpyder
Never mind -- a friend figured it out and sent me a link that had a version that worked for me. How he found it, I don't know... But I'm back in business!
How was this version of Calibre built to run on an older MAC OS? Please ask your friend. Also, it would be helpful to post the link.
Reply 

#4  downeaster59 10-05-2019, 08:40 PM
Try this link!
Reply 

#5  JSWolf 10-06-2019, 08:35 AM
Quote downeaster59
Try this link!
That's the official link and that won't work on OS X below version 10.14. I'm asking for the information on the version of Calibre 4.0 that is working on OS X 10.13.6.
Reply 

#6  dwig 10-06-2019, 09:05 AM
Quote JSWolf
That's the official link and that won't work on OS X below version 10.14. I'm asking for the information on the version of Calibre 4.0 that is working on OS X 10.13.6.
True, that's primarily the link to the new v4.0 installers, but it also contains the official link to the previous versions. Just look down the page to the line below the credit card badges and these is a link to the older versions that has been present on the page for years.

For users in the OP's situation, the last of the v3.x installers is likely the best choice.
Reply 

#7  JSWolf 10-06-2019, 09:28 AM
Quote dwig
True, that's primarily the link to the new v4.0 installers, but it also contains the official link to the previous versions. Just look down the page to the line below the credit card badges and these is a link to the older versions that has been present on the page for years.

For users in the OP's situation, the last of the v3.x installers is likely the best choice.
It reads like someone has managed to fix Calibre 4.0 to get it to work on OS X prior to 10.14. I know all about the official released. So what I want to to find out how to get it working on OS X prior to 10.14 for all those who cannot update OS X. So please just leave the official links/releases out of this.
Reply 

#8  kyteflyer 10-06-2019, 01:45 PM
Quote JSWolf
It reads like someone has managed to fix Calibre 4.0 to get it to work on OS X prior to 10.14. I know all about the official released. So what I want to to find out how to get it working on OS X prior to 10.14 for all those who cannot update OS X. So please just leave the official links/releases out of this.
Not really. When I read it I interpreted it to mean he had found a version, not necessarily the latest, (if thats 4) which would work for him. The official links are useful for others looking for older versions, too.
Reply 

#9  downeaster59 10-06-2019, 02:00 PM
Quote kyteflyer
Not really. When I read it I interpreted it to mean he had found a version, not necessarily the latest, (if thats 4) which would work for him. The official links are useful for others looking for older versions, too.
This.
Reply 

#10  ceb 06-29-2020, 03:44 PM
Quote RevSpyder
Never mind -- a friend figured it out and sent me a link that had a version that worked for me. How he found it, I don't know... But I'm back in business!
Can you share? Somehow I lost my version of Ca'ibre for OS10.13.6.
Reply 

  Next »  Last »  (1/2)
Today's Posts | Search this Thread | Login | Register