Mobileread
Mobi2Mobi Mobi2Mobi v0.13 - GUI for Mobiperl tools
#11  Ortep 03-07-2008, 07:37 AM
I really like a gui. Great job but I think I found a new bug.

The program starts, I can select the working directory, but as soon as I click the open file button I get:
Error.jpg 
Reply 

#12  Jad 03-09-2008, 10:21 PM
Well the GUI is now almost a true frontend for Mobi2Mobi. I finally figured out the code to read the Mobi2Mobi output to parse out Author & Publisher details. I'll start playing with Cover Images next to get that working.

I also fixed the default eBook directory feature, which was supposed to work in v0.02 but due to my fat fingers I deleted a .Text in the wrong spot somewhere along the line and poof it stopped working.

Also quite a few people are having exception errors when using the GUI. You absolutely 100% must have Service Pack 1 for .NET Framework v2 installed. The only really easy way to check this is to open Add Remove Programs in the Control Panel and see what it says. The .NET Framework 2 entry should have Service Pack 1 as part of its name. If it doesn't you will need to install it.
[zip] Mobi2Mobi_GUI_v003.zip (9.3 KB, 2350 views)
Reply 

#13  JSWolf 03-09-2008, 10:57 PM
I've merged the threads because there is no need for seperate threads for every new version.

Jad, you might want to remove the 002 attachment and place the 003 in place of it.
Reply 

#14  Jad 03-09-2008, 11:03 PM
Thanks JSWolf, I've updated the original post with the new version of the GUI.

Did SP1 for .NET v2 fix your crashing problems??

Cheers again.
Reply 

#15  JSWolf 03-09-2008, 11:05 PM
I just tried .03 and it didn't work. I'd put in the info and click convert and nothing.
Reply 

#16  Jad 03-09-2008, 11:06 PM
Did you tick the appropriate boxes for the fields you changed?
Reply 

#17  JSWolf 03-09-2008, 11:07 PM
Quote Jad
Thanks JSWolf, I've updated the original post with the new version of the GUI.

Did SP1 for .NET v2 fix your crashing problems??

Cheers again.
I already had the latest Net v2 with all the patches. That wasn't a problem.
Reply 

#18  JSWolf 03-09-2008, 11:08 PM
Quote Jad
Did you tick the appropriate boxes for the fields you changed?
Sure did. And when I installed .03, I put it in the same directory as I had .02. And that directory does contain mobi2mobi.exe and is in the path as well.
Reply 

#19  Jad 03-09-2008, 11:09 PM
Sorry, quite right... Thinking of the wrong bug. I'll try again =8) I hope you haven't received the file in use problem again.
Reply 

#20  Jad 03-09-2008, 11:12 PM
Are you modifying an existing .MOBI file? The feedback window should output the contents of the converted file. Did you change the output filename at all, or did you leave it as original? I'm just trying to figure where the possible break might be.

Cheers
Reply 

 « First  « Prev Next »  Last »  (2/48)
Today's Posts | Search this Thread | Login | Register