HELP! PRS-T1 Opening book loop...
#1  njosnari 10-12-2019, 05:56 AM
So my PRS-T1 sat unused for quite awhile and I recently dug it out. Battery was flat dead, and when I recharged it, things were fine. Like an idiot, i decided to check if any updates were available and installed. About a week later, I'm stuck in this opening book loop, where the status bar doesn't move, and then the screen flashes white, just to land on the same page, and repeats over and over. I thought that maybe the battery was borked, so I've installed and charged a fresh one, and still the same. I've tried to follow up on restore/rescue options, but I'm rather confused. The latest rescue SD seems to be for 1.0.04, and thats not even available anymore... I've downloaded an image of a clean 1.0.07 install, but I have no clue what to do with it..

Does anyone have any suggestions on what I can try to bring this thing back to life?

#2  DoctorM 10-13-2019, 01:07 AM

More details if you need it with working links to software used:

#3  njosnari 10-13-2019, 06:56 AM
Hi DoctorM
I'm trying to follow the instructions here, and I've done these steps:
Download Porkupan's SD rescue package for 1.01/1.02/1.03 firmware or uboot's SD rescue package for 1.04 firmware. Copy the folder "OS Firmware" to the root directory of your micro SD card and insert the card into the reader.
Press and hold HOME and MENU before pressing POWER on the Reader and keep HOME and MENU pressed (this is crucial!)
Wait until the progress bar in the “Opening book" page has reached the right side (about 20 seconds). The message will change to “Updating”. Release buttons. From now on there should be no more visible activity except for the constant blinking of the orange light (within the power button).

However, once the progress bar fills up, nothing happens. The loop resumes as it did before.

#4  DoctorM 10-14-2019, 12:02 AM
I'm guessing you tried resetting with a paperclip.
The only other thing I can think of that I've done in the past is modify the Sony flasher utility by changing the version number to a lower number, flashing the Reader and bricking it to stop the reboot loop.
I wouldn't recommend intentionally doing that though.

#5  njosnari 10-14-2019, 04:29 AM
Yes, the only way to do the shut down is to hold reset + power for a few seconds... So there is no way out of this loop?

#6  njosnari 10-14-2019, 04:37 AM
What is the sony flasher utility? Would I be able to use that? I can't even connect my PRS-t1 to my computer with usb.

#7  DoctorM 10-15-2019, 12:30 AM
Quote njosnari
Yes, the only way to do the shut down is to hold reset + power for a few seconds... So there is no way out of this loop?
Are you saying you can shutdown, but starting it up again with HOME and MENU doesn't start a firmware flash?

#8  njosnari 10-15-2019, 04:51 AM
By "shut down", I press reset and power for a few seconds, and the opening book loop stops refreshing. When I press HOME and MENU, either after "shutting down" or when the loop refreshes itself, the progress bar will fill all the way up, but it will never change to "updating"

#9  JSWolf 10-15-2019, 05:02 AM
Looks like it's time for a new Reader. Having used a T1, I moved to Kobo with a larger screen and I'm glad I did. If you do decide to get a new Reader, I highly recommend the 7" Kobo Libra H2O. It will so make your reading experience much better.

#10  DoctorM 10-16-2019, 12:35 AM
Yeah. I gotta agree with JSWolf. If you can shutdown and restart with Home+Menu and it won't update from the SDCard, I think it's done.

  Next »  Last »  (1/5)
Today's Posts | Search this Thread | Login | Register