Mobileread
Calibre on Puppy Linux
#1  jeffneedle 11-05-2019, 07:31 PM
Hi. Not sure if this is the right place to post this. I'm using Puppy Tahr 6.0.5. A very stable version of Puppy. 64-bit. Under the Puppy hood there's an option called Quickpet. You install Calibre here. In the past, Calibre installed just fine. Now, Calibre seems to install just fine, but it won't open from the menu. Running from terminal gives this output:

Traceback (most recent call last):
File "site.py", line 77, in main
File "site-packages/calibre/gui_launch.py", line 72, in calibre
File "site-packages/calibre/gui2/__init__.py", line 16, in <module>
ImportError: cannot import name QT_VERSION

Anyone use Puppy, or can understand the problem and supply a fix? Thanks.
Reply 

#2  kovidgoyal 11-05-2019, 09:25 PM
See th enotes about minimum required versions of system libraries on the calibre linux download page. Your OS probably does not meet them.
Reply 

#3  jeffneedle 11-05-2019, 10:23 PM
Thanks so much. I've been working hard on figuring this out. Previous installs of calibre work just fine. The difference? It seems that calibre 3.x uses the qt4 framework; v. 4.x requires qt5. The key will be to figure out what to install on my computer.

Thanks again.
Reply 

Today's Posts | Search this Thread | Login | Register