iRiver Story: Epub with diacritics
#1  radub 03-20-2010, 05:45 PM
Hello all,
I have some .rtf files which contain diacritics. Since the iRiver can't use them, I converted them to epub with Calibre 0.6.45 (under Linux). The Ebook Viewer shows the diacritics correctly for both the rtf and the epub, and I can also see them in another Linux software that displays epubs called Okular. But on the iRiver the diacritics are replaced by question marks.
Any advice on how to fix this? I can see diacritics on the iRiver, but not where needed.

#2  wallcraft 03-20-2010, 06:09 PM
This is most likely due to the default font used by mobile Adobe Digital Editions. Almost all vendors are using Adobe's provided font, and it does not include many glyphs.

On some devices it is possible to provide your own fonts for mobile ADE (with a small addition to each ePub's CSS), but I don't recall reading about anyone doing this for the iRiver. The other option is to embed a font in the ePub. For a recent discussion of this, see Esperanto characters?

#3  radub 03-20-2010, 07:29 PM
I've read that, then I went here, but it didn't worked. Next thing is to embed fonts into the epub, but Calibre doesn't do that yet, and this method isn't practical for hundreds of books (if it works, that is...)
I'll try this tomorrow.

#4  wallcraft 03-20-2010, 08:01 PM
Quote radub
I've read that, then I went here, but it didn't worked.
For this to work you need to know what to use in place of the Sony's "Data/" on the iRiver. On the Hanlin V3/V5 it is "abook/" and on the Nook it is "sdcard/". All these are related to how the internal memory or SD card are normally named on the device, but to find the right name for mobile ADE requires luck and detective work.

#5  radub 03-20-2010, 08:33 PM
Well, the iRiver has a "font" directory on its internal storage (when mounted), but I have no idea what's the real path for it. iRiver runs Linux, I'll try to loopmount a firmware and see where is that folder...
Also: Calibre didn't embedded my custom css! I had to embed it by hand.
Is this css sane, in your opinion?
@font-face { font-family: "Biolinum"; font-weight: regular; font-style: regular; src: url(res:///font/Biolinum.ttf);
body { font-family: "Biolinum", default;

#6  wallcraft 03-20-2010, 11:57 PM
For embedding fonts in the ePub, see How to embed fonts in ePub after Calibre. Note that it does not require the "res:///", because the fonts are located relative to the CSS file within the ePub.

It might be possible to reference the system font directory, but it is more useful to reference a font directory that is user accessible. On the Bookeen Opus (for example) both might be possible, see Fonts directory for Calibre -> External CSS. It is using "mnt/fat/" as the location for the internal memory (accessible by the user, i.e. where the ebooks go). Every device seems to use a different file location convention, and which locations are legal after "res:" depends on how mobile ADE is configured by the vendor.

#7  radub 03-23-2010, 03:13 PM
Ok, here's something funny: I looked inside the firmware and found 2 fonts. Guess what, both have my much-needed diacritics! But why they don't display them, is a mystery to me.
I'd just like to say that I made my troublesome epub from a rtf file, would the encoding of the rtf be an issue? The .rtf is ansi-1252, not utf-8. Maybe the iRiver can't read ansi? When Calibre converts to epub, does it keep the encoding of the source?

Today's Posts | Search this Thread | Login | Register