Mobileread
To Update or not Update
#1  bookaho!ic 09-27-2020, 11:36 AM
If my version of Calibre is working is there any need to update? I am generally of the ilk that if its not broke dont fix it. Will there be a time that i cannot connect my kobo? I am running 4.21
Reply 

#2  ownedbycats 09-27-2020, 12:18 PM
If you make heavy use of DeDRM (or other plugins that haven't been ported to Py3), may be best stick with 4.xx for now.

If you're using Windows 7, also want to stick with older versions.

My Kobo Aura HD connected fine after update. Occasionally a new firmware update will be incompatible with the current version of Calibre but there's an option to force it anyways. Hasn't ever broken anything on my end.
Reply 

#3  JSWolf 09-27-2020, 12:28 PM
Quote bookaho!ic
If my version of Calibre is working is there any need to update? I am generally of the ilk that if its not broke dont fix it. Will there be a time that i cannot connect my kobo? I am running 4.21
You should update to 4.23 at least. Nothing will break because of this.

Check the plugins that you use and make sure that they are updated to work with Calibre 5. Some are still to be done and some are being worked on and some are abandoned.

The DeDRM plugin is not yet Calibre 5 compatible. As for the rest, check https://www.mobileread.com/forums/sh...d.php?t=326405 to see if the ones you use are compatible.

If you are on Windows and you run the DeDRM plugin and everything else is good to go, you could run the 4.23 portable to run DeDRM and use 5.x for everything else.
Reply 

#4  bookaho!ic 09-28-2020, 03:38 AM
Thanks guys
Reply 

Today's Posts | Search this Thread | Login | Register