Chapter 31 - 0
#1  Turt99 05-12-2010, 08:47 AM
Anyone else have this issue?

I'm currently reading a book that I used Calibre to convert and had it look for the style "chapter" to split the file for chapters and create a TOC. The TOC seems to have worked in that I can use the menu on the Kobo to select "Table of Contents" and move around the book.

But then I turn the Kobo off or look at the I'm reading page I see that I'm on "Chapter 31 of 0" or something to that effect.

I might have made an additional change to the file in Sigil to play with the stylesheet as well so that might be related to this issue as well.

#2  Stinger 05-12-2010, 09:14 AM
I've only experienced this with books that don't have a TOC.

I was going to ask if your TOC had an unusually large number of chapters, it might be a bounds issue, but I just created a book with 295 chapters and it showed properly.

Have you tried deleting the epub from the Kobo, unpluggin the device, plugging it back in, and copying it back over? (essentially, forcing the kobo to reprocesses the book)
I've had some issues with making changes to cover art and the Kobo not recognizing it due to some form of caching until I did the above. Might be the same if you added a book without a TOC, and then just changed the file on the kobo.

#3  Turt99 05-12-2010, 09:27 AM
Hrm, this might be true. I might have just added the Table of Contents after it was already loaded.

Right now I'm reading the book so I'm not sure I want to play with it, as I would have to page around to it again but I think I might clear my Kobo library and slowly load the books as I get them all fixed up with chapters and formatting and everything.

Today's Posts | Search this Thread | Login | Register