Mobileread
Sigil 0.1.1
#1  Valloric 08-05-2009, 09:18 PM
Sigil v0.1.1 has been released. The ChangeLog for this release follows:

Quote
Sigil v0.1.1 2009.08.06.
- applied provided patch for NetBSD support
- fixed issue with loading images in HTML and EPUB docs that have regexp special characters
in filenames. (issue #39)
- if headings have the 'title' attribute set, it is now used as the TOC text entry. (issue #26)
- tags are now removed from headings before they are converted to TOC entries (issue #47)
- Sigil now remembers the last folder from which you loaded an image (issue #34)
- choosing 'cancel' in TOC editor now no longer forces the views to update
- fixed bug with new headings getting existing IDs. (issue #36)
- printing support! new file menu actions: "print" and "print preview"
- fixed an issue when sometimes switching between views didn't enable/disable appropriate actions
- fixed an issue with mixed-up CSS classes on Mac and Linux (issue #16)
- added line numbering for Code View (issue #9)
- added current line highlighting for Code View
- fixed crashed bug with some calibre generated epubs (issue #16)
The Mac build has been very kindly provided by MobileRead member pilotbob. The Mac machine I used is not available until next Sunday* so I had to recruit someone to do the mac build, and pilotbob came to the rescue.

I am also told that there are some problems with building the mac version from source... Unfortunately I can't work on this until I get a mac near me. DMG users are of course not affect by this.

Linux users should notice there is no binary build for their platform. The previous version had one, and that didn't work out too well. For now, just build it from source:
Code
$ cmake -G "Unix Makefiles"
$ make
That's it. Look in the "bin" folder for the compiled binary.

*I don't actually own a Mac. A friend of mine owns one, but he's gone temporarily out of town. Great timing, isn't it?
Reply 

#2  zelda_pinwheel 08-05-2009, 09:21 PM
woo hoo !! already up to 0.1.1 !! i'm happy about code line numbers. very, very happy.

by the way, you should add a link to your signature to go directly to the google code page as well.

thanks valloric !!!
Reply 

#3  Valloric 08-05-2009, 09:24 PM
Quote zelda_pinwheel
by the way, you should add a link to your signature to go directly to the google code page as well.
I turn off display of signatures on any forum that allows this, so I don't really perceive them. This includes my own

But thanks, I'll fix it now.
Reply 

#4  Moejoe 08-05-2009, 09:24 PM
Thankyou for this new release. Compiling now
Reply 

#5  zelda_pinwheel 08-05-2009, 09:29 PM
Quote Valloric
I turn off display of signatures on any forum that allows this, so I don't really perceive them. This includes my own

But thanks, I'll fix it now.
oh the irony.

by the way, the "about" screen still says v.0.1.0 completely unimportant, i know, but i just wanted to admire the landmark.
Reply 

#6  zelda_pinwheel 08-05-2009, 09:30 PM
(should i stop making work for you with "by the way" in every post ? )
Reply 

#7  Valloric 08-05-2009, 10:01 PM
Quote zelda_pinwheel
oh the irony.

by the way, the "about" screen still says v.0.1.0 completely unimportant, i know, but i just wanted to admire the landmark.
Great. I knew there was something I forgot.
Reply 

#8  AprilHare 08-06-2009, 03:40 AM
Quote Valloric
Great. I knew there was something I forgot.
Sorry, forgot to tell you Noticed it on my AMD64 build..
Reply 

#9  marcostt 08-06-2009, 04:54 AM
Thank you for the quick update

But, there is some problem with the mac version... I did dowloaded the v0.1.1 from here http://sigil.googlecode.com/files/Sigil_mac_0.1.1.dmg I did installed, and after run it in "About" is named 0.1.0, and still can not open Calibre`s epub.
Reply 

#10  Jellby 08-06-2009, 07:35 AM
Grrr... After compiling Qt 4.5.2, I get this:

WARNING: This project requires version 2.6 of CMake. You are running version 2.4.8.

So I once again ask for pre-compiled static versions, if possible

I'm using a Mandriva 2008 system, but it's sort of in production state, so upgrading now is not the best option.
Reply 

  Next »  Last »  (1/3)
Today's Posts | Search this Thread | Login | Register