Mobileread
Unable to install plugins on Mac (invalid plugin msg)
#1  momoha 02-24-2021, 06:48 AM
Hi,

So my collegue (who doesn’t speak english) is trying to install plugins on Sigil on Mac, but for any plugin, she is unable to do so. First, when trying to select the zip file of the plugin, it simply doesn’t show up, like if it wasn’t recognized. Then, when she types the file name manually to add it, it shows the following message (plugin invalid).

The zip file is the original one, it hasn’t been decompressed and is untouched (she downloads it with Chrome). She tried installing the latest version of Python and ActiveState, and it didn’t change anything.

Does any one has a clue as why this problem is happening?

Thanks!
Capture d’écran, le 2021-02-23 à 09.02.14.png 
Reply 

#2  DiapDealer 02-24-2021, 08:22 AM
Either the plugin's zipfile is being automatically unzipped (or automatically renamed) by some sort of download helper, or the file-browser (or addon) is allowing them to browse into the zip archive rather than selecting it.

Hopefully one of our regular Mac users will see this and have better instructions.
Reply 

#3  KevinH 02-24-2021, 08:41 AM
A few things ...

1. The correct Python is already part of Sigil on macOS and no additional Python installation is needed by Sigil. Please uninstall whatever version of Python you installed unless you need it for some other reason.

2. Some plugins are platform specific and will not run on macOS. Could it be a Windows only plugin?

3. If he/she tried to manually install a plugin by unpacking it in the wrong place they will have to manually remove what ever they did.

4. The Sigil plugin preferences check box for use embedded Python should always be checked on macOS as that one has the required pieces. That is the default setting and it should not be changed.

Also MacOS many users has set a Mac Preference to "open safe files" after download or some similar wording. This results in the zip archive being unzipped automatically. In addition, the macOS gatekeeper marks downloaded files to quarantine them.

So the best procedure for macOS is to:

1. Make sure to uncheck the Mac preference to open safe files after download first
2. Download the plugin and it should appear a true zip file in the Mac Downloads folder
3. ***Do Not skip this step*** Manually drag and drop that plugin zip archive from the Downloads folder to the Desktop. This tells macOS gatekeeper that you recognize the file so it will loosen its quarantine. Never try to run or install anything directly from the macOS Downloads folder. Macs restrict that for extra protection.
4. Use Sigil Manage Plugins to install the plugin from the Desktop folder.
Reply 

#4  KevinH 02-24-2021, 12:12 PM
Also the exact name of the plugin zip archive is important and can NOT be changed. The folder name inside the zip must match the plugin basename exactly. So do not try to rename the plugin zip file.
Reply 

#5  Doitsu 02-25-2021, 12:55 AM
Quote momoha
Does anyone have a clue as to why this problem is happening?
What's the name of the plugin?
Reply 

#6  momoha 02-25-2021, 03:45 AM
Quote Doitsu
What's the name of the plugin?
She tried with both ePub3-itizer and PageList.
Reply 

#7  Doitsu 02-25-2021, 12:03 PM
Quote momoha
She tried with both ePub3-itizer and PageList.
Both should also work with the macOS version of Sigil.

She could try to manually install them as follows:For example, for the PageList plugin, she'd need to copy the \PageList folder to the Sigil \plugins folder.
(The PageList plugin folder should contain a plugin.py file and a plugin.xml file and no other folders.)
Reply 

#8  KevinH 02-25-2021, 12:08 PM
That should never be needed on macOS. If that turns out to be required, then something funny is going on when downloading the plugins. Has she/he followed the directions I posted earlier in this thread.
Reply 

Today's Posts | Search this Thread | Login | Register