TL3/626 Can't write on internal memory
#1  sulfi 09-22-2016, 01:20 PM

My touch lux 3 is brand new from this morning.
I'm trying to update the firmware.

When i'm trying with the wifi to do the update i have always an error that the file is corrupted.

When i copy on the internal memory, the files disappear when i reboot....
The ereader never finds the files. I connect the all back, and no update files on the ereader.
When i do a new folder on the internal memory and i reboot, no new folder.

What im doing wrong ?

PS: it's my second touch lux 3, for the first one the wifi never worked.....

Can someone please help me ?

#2  brucelee 09-23-2016, 07:53 AM
You're one unlucky guy. I never had such issues with any of my PB devices. Did you try a factory reset?

#3  DaleDe 09-30-2016, 12:16 PM
I would suggest reformatting the memory after backing up the data. The manual should tell the steps or go to the web site.


#4  brucelee 11-02-2016, 11:04 AM
Did you figure anything out?
I seem to be in the same position now. My PB TL3 went out of battery over night and since then the internal memory is read-only.
Tried factory reset, formatting, FW update. No luck yet.

Tried deleting partition with gParted from Ubuntu PC, created new fat32 partition. I've mounted the partition and it was empty. After disconnecting and reconnecting things were back like nothing happened.

#5  brucelee 11-02-2016, 12:36 PM
I've sent an email to the PB customer support. Hopefully they'll come up with a solution.

I have my Touch Lux 3 since July 2015 and I never had any issues with it until a couple of days ago.
The thing is that the device went out of battery over night and since then I can't change anything in the internal memory.
I've tried formatting, factory reset, upgrading firmware, formatting with an Ubuntu PC. Nothing happened.
If I connect the device to the PC, create a folder, safely remove the device and reconnect it to the PC the folder disappears. If I remove something from the device library app and reboot the device it shows up again.
It seems that whatever I do I can't bring any change to the internal memory. Settings, books, other files... Everything is read-only.

I also had quite a few models prior to upgrading to Touch Lux 3 (515, 624, 626-TL2) and I didn't encounter this issue.
I also have a memory card which seems to be writeable. I've tried removing the memory card before doing all the formatting and resetting stuff but with no luck.

The device wasn't dropped, wetted or anything like that. I have a cover case for it and I'm quite careful with it.

This issue seems to have happened to someone else too:

Is there anything I can do about it?

#6  nhedgehog 11-02-2016, 01:32 PM
This sounds like an faulty micro SD card (flash memory) inside.
I think it started with PB626 that the previously soldered internal flash memory chip was replaced with a micro sd card inside a holder.
When I opend mine to repair the faulty LED cable I saw this micro sd card. I have some Micro SD cards here which show the same symptoms (no write access but read access), formating ending without doing anything. What prevented me from removing this card from the folder and make an image was, that I wasn't sure I could put it back safely.

PS: Under Linux it should be easier to access the faulty card. My system is XP.

#7  brucelee 11-02-2016, 01:36 PM
I thought about that too but I'd expect it to go wild after encountering a shock or something. Which was not the case.
Putting the card back is the reason I'm not getting it out in the first place too.

#8  nhedgehog 11-02-2016, 02:08 PM
I'm sure I read something about replacing the internal sd from Kobo or Tolino devices (reading the image and writing it on another sd).
I even searched for some images of the PB626 sd but it was strange, I couldn't find one.
Don't think there is a way around replacing that internal micro sd.

#9  brucelee 11-02-2016, 02:12 PM
Quote nhedgehog
I even searched for some images of the PB626 sd but it was strange, I couldn't find one.

#10  nhedgehog 11-02-2016, 02:19 PM
Ok, I was not specific enough. I meant an micro sdcard-image, done with some tools like DiskImage.

Here is the thread:

  Next »  Last »  (1/12)
Today's Posts | Search this Thread | Login | Register