Mobileread
Server option:--book-list-mode
#1  gpm 10-28-2020, 01:21 PM
I'm running calibre-server on a Raspberry Pi. (Raspbian OS 'Buster')
I tried the option "--book-list-mode" without success: server doesn't start - unknown option...
The manual just mentions it but gives no arguments.
I tried some, just guessed, but I failed.
The log says there is no option like that.
Besides of not known arguments I assume a certain version from up there this would work.

It would be helpful to use, because I mustn't explain new users how to set this.

Qs:
What are possible arguments?
Which version is needed to use that?

Thanks for every help.
Reply 

#2  DNSB 10-28-2020, 03:37 PM
Quote gpm
I'm running calibre-server on a Raspberry Pi. (Raspbian OS 'Buster')
I tried the option "--book-list-mode" without success: server doesn't start - unknown option...
The manual just mentions it but gives no arguments.
I tried some, just guessed, but I failed.
The log says there is no option like that.
Besides of not known arguments I assume a certain version from up there this would work.

It would be helpful to use, because I mustn't explain new users how to set this.

Qs:
What are possible arguments?
Which version is needed to use that?

Thanks for every help.
One question is what version of calibre are you running on your Raspberry Pi?

Using calibre 5.30 under Windows, when I started the server from the command line with the --book-list-mode option ?, it gave the following output:
Code
calibre-server.exe: error: option --book-list-mode: invalid choice: '?' (choose from 'cover_grid', 'custom_list', 'details_list')
I tend to suspect you are using an older version of calibre that did not support the option.
Reply 

#3  gpm 10-28-2020, 04:02 PM
@David
Thx for reply.
I'm on Raspbian OS 'Buster', so I believe the current version of calibre is 3.39. No other version found so far.
But at least I know now the possible arguments.
The reminding question is from what version on up is this available?
Reply 

#4  gbm 10-28-2020, 04:11 PM
Quote DNSB
One question is what version of calibre are you running on your Raspberry Pi?

Using calibre 5.30 under Windows, when I started the server from the command line with the --book-list-mode option ?, it gave the following output:
Code
calibre-server.exe: error: option --book-list-mode: invalid choice: '?' (choose from 'cover_grid', 'custom_list', 'details_list')
I tend to suspect you are using an older version of calibre that did not support the option.
This is the command I use on my linux pc to start the server using the book list.

Code
calibre-server --book-list-mode details_list
bernie
Screenshot from 2020-10-28 15-10-32.png 
Reply 

#5  gpm 10-28-2020, 05:13 PM
Quote gpm
@David
Thx for reply.
I'm on Raspbian OS 'Buster', so I believe the current version of calibre is 3.39.
To be precise: calibre-server (calibre 3.39.1)
Code
calibre-server --book-list-mode ?
gave me:
Code
calibre-server: error: no such option: --book-list-mode
So I'm clear with that.
The leftover question is: From what version on up is this available?
Reply 

#6  kovidgoyal 10-28-2020, 11:17 PM
Dont recall the exact version, but you will be sure to have it from 4.23 onwards.
Reply 

Today's Posts | Search this Thread | Login | Register