Mobileread
Is there a list of which devices can read which pdfs?
#1  MarjaE 07-19-2020, 12:16 AM
For example, Kindle 2 and Kindle Dx can show:

* Most pdfs up to 1.4 without trouble, and 1.5+ without passwords by dropping newer image formats.

* Note that Internet Archive scans routinely use newer image formats, and you need Willus's k2pdfopt to make them readable.

* Ghostscript output up to 1.3 without trouble, and 1.4+ with trouble with overlapping images.

* Note that when pdfs rely on layers, this can't remove layers to make text readable.

Saying "these can show pdfs" isn't enough information, since they require so much pre-processing for newer pdfs.

Saying "up to 1.4" is fairly accurate, except for Ghostscript output.

Saying "yes, but trouble with transparency, and they can't show jpx or jbig, layers, or files with passwords," would be more accurate.
Reply 

#2  DaleDe 07-21-2020, 07:30 PM
Try our wiki PDF#PDF_Viewers@Wiki ». Add or fix anything that you need.

Dale
Reply 

#3  MarjaE 07-21-2020, 10:47 PM
Thanks.

I can't see where I am to edit the tables. As it is, they don't say much about compatibility. For example, the Kindle Dx listing doesn't note that it can't handle password-protected pdfs, jpx images in pdfs, has trouble with transparency in pdfs processed in Ghostscript, etc.

None of the entries I've seen touch on jpx images.
Reply 

#4  DaleDe 07-22-2020, 02:00 PM
Quote MarjaE
Thanks.

I can't see where I am to edit the tables. As it is, they don't say much about compatibility. For example, the Kindle Dx listing doesn't note that it can't handle password-protected pdfs, jpx images in pdfs, has trouble with transparency in pdfs processed in Ghostscript, etc.

None of the entries I've seen touch on jpx images.
Tap the help button to learn how to edit the pages. It is best if you have a username in the wiki. There is always room for improvement.

Dale
Reply 

Today's Posts | Search this Thread | Login | Register