Mobileread
HELP-Start Calibre-Server DOS Comand Line
#1  JimJoatMon 10-17-2019, 11:51 PM
I wish to start the Calibre-Server with a batch file on my Windows 10 machine. I do not want the main Calibre program to be running on this machine.

The contents of my batch file used to be:
calibre-server --port 2658 --with-library "D:\Calibre Library" --password xxxx --username yyyy

This no longer works with the newer version of Calibre. I have setup a "sharing over the internet" within Calibre and that works fine. I am assuming that the user/password is accessible to a command line launching of calibre-server and that I don't have create this single user again from the command line.

I have also set up port forwarding in my router.

When I launch Calibre-Server from command line I get:


calibre server listening on 0.0.0.0:8080
OPDS feeds advertised via BonJour at: 192.168.1.18 port: 8080


I have no idea what OPDS or BonJour mean, and I do see a switch to stop that,but what else do I need on the command line. To make this work?

So far I got:
calibre-server --port 2658 --enable-auth --disable-use-bonjour "D:\My Caibre Library"


Thanks,

Jim
Reply 

#2  nqk 10-18-2019, 01:02 AM
calibre-server --port [port] --enable-auth --auth-mode basic --disable-use-bonjour "[Library]"


This works with me.
Reply 

#3  JimJoatMon 10-20-2019, 09:10 PM
Quote nqk
calibre-server --port [port] --enable-auth --auth-mode basic --disable-use-bonjour "[Library]"


This works with me.
Thanks I added --listen-on [Computer IP] and all is OK
I also had some problem with the Computer firewall, and that 'muddied the waters"

All is good!

calibre-server --port [port] --enable-auth --auth-mode basic--disable-use-bonjour --listen-on [Computer IP] "[Library]"
Reply 

Today's Posts | Search this Thread | Login | Register