Mobileread
Tolino Vision 2 Bricked after december update
#1  pompopom 02-16-2021, 01:41 PM
Hi everyone,

I'm new here, sorry for the long post to come... I you hate reading jump to help smiley.

My better half was a happy Tolino user for several years. Last December '20 she was prompted to do an update as many updates before that. So she just proceeded as usual. However this time: no luck. After the apparent succesfull update the Tolino froze. No reaction whatsoever. Connecting it to a PC still gave the device detected sound bleep thing but it didn't appear anymore in explorer.

So after some Googling and restarts we proceeded to the "full reset" (the-tiny-hole-next-to-the-USB-connection-reset) If I recall correctly a that time we received a menu with 3 or 4(?) options. There was a simple "restart", "something else" and a full factory reset which would wipe everything off. We did the first options to no avail and finally proceeded to the full wipe.
I might not be entirely correct in the menu's described, as I don't recall them and I can't seem to find in Google images a screenshot which comes even near to what was prompted to us.

Anyway the full reset. At that time I saw on the screen some kind of re-installation of the software coming to live. Yaaih!! NOT... at a certain point it seemed to freeze again. We left the Tolino overnight to find it in the morning in the same state. So we restarted it.

After that the only thing showing on the screen is the Tolino logo with butterfly. The led next to the power button blinks and the "home" button reacts as that backlight come up briefly. My better half deeply dissapointed. As I didn't have time at that moment to really deep dive into it she just bought a new device. The "Standaard Boekhandel" here in Belgium decided anyway to stop cooperation with Tolino and go for another eReader partner anyway.

Nevertheless a few months later I would like to get this reader back to life. After Sales send us a "No repair possible, to old device" kinda reply. So I'm trying my luck myself.


So status:
As mentioned: The only thing showing on the screen is the Tolino logo with butterfly. The led next to the power button blinks and the "home" button reacts as that backlight come up briefly.
If I press power button for few seconds the Tolino seems to shut. Blinking led stops, but the logo remains on the screen.
If I press the "full reset" next to the usb socket, the home button backlight comes up, but nothing more. logo remains on the screen.
When I push the power button again the screen blinks 2 times but ends in showing the logo again and the led blinking next to power button.

So what have I tried so far:
- Recharge battery (left it 2 days on the charger)
- Opened the Tolino and replaced the battery
- Hooked up a usb to serial adaptor (115200 8N1) on 3.3V and tried all of the serial ports I discovered under the hood.
On one of them (the second from the top) I receive the following output when "turning on" the Tolino:
Code
0609 CSum:d739,CSumRd:d739
Jump to APP1▒▒▒Wait Host Ident
->Got Host Ident
* Sleep *
***Wake Up!!*** , LLWU_F1: 20 , LLWU_F2: 0 , LLWU_F3: 0
*RxEStop!RxCnt:3. .Gdata(3):3E 00 03
~>Ident PulseFlag=FALSE
* Sleep *
***Wake Up!!*** , LLWU_F1: 20 , LLWU_F2: 0 , LLWU_F3: 0
* Sleep *
IMO the thing that needs to be done is reflash the program memory over the serial port. Googled a lot, but no really helpfull info to be found. So I stumbled upon this forum where apparently some people hacked/rooted their Tolino.
Soooo I suppose I came to the right place.

Can anyone point me into the right direction on how to proceed?
Or maybe it's something more obvious then what I'm looking for and some magic button code/sequence solves the issue :-)

Kind of my last hope...
Thx for the read and the help in advance.

regards,
Koen
Reply 

#2  ottischwenk 02-16-2021, 03:33 PM
Look at http://forum.alles-ebook.de
Reply 

#3  pompopom 02-16-2021, 05:13 PM
Quote ottischwenk
Look at http://forum.alles-ebook.de
Thx for the tip. Can you give a more exact topic on that forum? My German isn't really that good to have the correct search terms.

Meanwhile myself had stumbled, via Google, upon the followoing:
https://www.e-reader-forum.de/t/tolino-vision-2-rooten.147429/

Which seems to be what I need, however again my German isn't that good to understand exactly what this person is doing. Also I don't really want to "root" my Tolino, just get the basic working again :-)
Reply 

#4  ottischwenk 02-17-2021, 01:57 AM
Try https://allesebook.de/anleitung/tolino-vision-recovery-modus-94661/
Reply 

Today's Posts | Search this Thread | Login | Register