KOreader on Android
#1  Ken Maltby 06-06-2014, 05:37 PM
The Android versions/releases of KOReader are still experimental. While it has worked fine on some devices running under some Android implementations, it may not work at all or not properly on your device.

Android port of the Koreader project is available now. For the current nightly build, with the latest features.

The WiKi.

It appears that the current nightly may not function well on all devices or Android versions, so you may want to try an earlier Nightly release or The Stable release.

Tap the top of the screen to bring up the menus. The same when in a document/ebook.
[Skip to post #3, for more tips]

T62/62+/C57ML users see post 35. The nightly referenced.

There is a lot of Android trouble shooting and fixing underway at Github, at the moment, there should be new versions soon that work on more devices and more reliably on some that were only marginal. The 20151027 nightly, published today 20151029, includes some changes that may improve Android compatibility.


#2  por 06-20-2014, 08:15 AM

On the M96 the app hangs when you try to load a PDF. The M96 is a e-ink reader with android 4.0.3.

The app starts and loads the file manager, but then if you try to open a PDF it hangs (becomes unresponsive).

#3  Ken Maltby 06-20-2014, 08:58 AM
With the Android version, the menu icon on the bottom of the screen will also bring down the File Manager menu.

A few tips to get started:

Once you have navigated to the beginning of your library, you might want to "long press" on the link to that page (the "./" at the top of a page that you can select from the beginning page) and you should be given the option to "Set as HOME directory".

(That is an example of one of the conventions used; A long press on setting options will often let you set that option as default. This is used for many of the menu items.)

On my 10.1" tablet I set the Progress Bar to "Full" [bottom menu, gear icon] and long press that to make it default. Then I go to [top menu, gear icon] "Status bar" and uncheck "Current page", as it is in the header for the "Full" progress bar.

You will probably want to set the "Screen" [top menu, gear icon] options, unchecking "E-ink optimization". You might also want to set the "Screen DPI" to match your device. Long pressing the "Custom DPI: 160" brings up a window to set it as you want. (Your Nexus 7 appears to be 323ppi)

One of the most useful features is the "History" menu item. It provides a listing of your previously opened files, with your current read at the top of the list. Selecting an item brings you back to wherever you were in that book. [ One thing I do on occasion is to extract the maps from an .epub or sometimes, download a better map, and convert them for display on my device as PNG files. Once I've opened them, they will appear in the History, along with the book. I can then, leave the book and go to History and select a map. After looking at the map, I can got to History again and select the book, returning me to where I left off.]

Oh, I should add that, for PDFs, you can set the default to "Zoom to fit content" by long pressing on that selection, of the "Switch zoom mode" menu item.

For adding fonts, dictionaries, and hyphenation dictionaries, see this post

For many of the menu settings, a long-press should get you a message box with the option to set that selection as the default.

The "Advanced Settings" menu presents you with many options that you can set/change by poking the all uppercase name of the option. This should give you a message box and keyboard to make the setting(s).

After making changes, upon leaving Koreader (Pressing the Home Icon) you should get a message box with: "You have unsaved default settings. Save them now?" Press "OK" and hopefully you will see a new message box with: "Default settings were saved successfully!"

That should be a start.


#4  por 06-27-2014, 09:12 AM
Quote Ken Maltby
Which build did you try?

Koreader uses a port of mupdf for pdf and cr3 for a number of other formats. Could you see if epub, pdb, txt, html, or some other file will open? You might try restarting Koreader, I seem to remember with one of the builds, I had to restart it after its first launch, but it worked fine after that.

I tried "koreader-nightly-20140627", the one just uploaded.

It turns out the reader works, just needed a very long time to open a pdf the first time. Unfortunately, it is unusable on the M96 because it is overall extremely unresponsive. I guess it's not optimized for such low specs.

#5  Ken Maltby 06-27-2014, 11:05 AM
Too bad you don't have the Onyx Lynx T68, it looks like an improvement on the AuraHD that I have, which runs Koreader and displays PDFs fine with a very good Reflow.

I don't know the minimum spec needed for good Koreader Android performance, but it runs fine on my old ASUS TF-101 tablet under Android version 4.0.3.


#6  PremaEbooks 06-28-2014, 11:57 AM

I'm testing 20140627 on M96, and it happens what por says. The app seems to run properly but there's no interaction with it. No buttom reactions, nor touch screen.
The Main menu seems to work but once there you can not interact with the app.

Hopefully on tuesday I will have a T68 on my hands and I will try to test all the apps I've tested on M96.

I'll tell you as soon as I begin to "play"

#7  Ken Maltby 06-28-2014, 12:23 PM
Quote PremaEbooks

I'm testing 20140627 on M96, and it happens what por says. The app seems to run properly but there's no interaction with it. No buttom reactions, nor touch screen.
The Main menu seems to work but once there you can not interact with the app.

Hopefully on tuesday I will have a T68 on my hands and I will try to test all the apps I've tested on M96.

I'll tell you as soon as I begin to "play"
What do you see if you tap the top of the screen on "FileManager"?
You can set the Language, Espanol is on the second page of language selections.
Can you navigate through your device's file system, while in the file manager?
The "../" takes you back toward the root. (On mine tapping that and the top item listed gets me to "Removable" then "MicroSD/" then "MicroSD32gb/, selecting that gives me the first page of my Library of ebooks. There the category folders are listed that lead to my ebooks/documents.

Tapping the top of a page when in a book or document brings up the top and bottom menus for that type of document/ book format. The tabs at the top and bottom change the options listed.

There was also a Wiki listed at the download site.


#8  PremaEbooks 06-28-2014, 03:35 PM
Hi Ken!

yep... I know, I can access the main root, or even my sdcard. Indeed the first thing you see when the app starts is "File Manager".
Ok, then I select one of the folders.
I managed to open an EPUB file (made by myself, we are a converting house) but once the cover is shown I can not go any further. Nothing works. Nor the touch screen neither any of the buttons. I can access the main menu... but nothing more.
I'm going to wait till I have my T68 on my hands. Test it, and try to record a video so you can see what I'm talking about.
I don't know exactly how you developed the app, I'm really starting with Eclipse and the Android thing... but... could it be an issue related to some code number that needs to be linked to the action/activity?
Just guessing...

All in all, I'll test it on my T68 ASAP...

Ok, I managed to see the options, I can select font-size, even rotate the screen. But it is really hard to go from "one place to the other".
It seems like if the app needed more RAM... every step takes a lot of time to be done.

Just in case you are not aware... Onyx M96 is running Android 4.03.
Maybe you need to compile the app on another version.

Again: just guessing, not trying to be rude It would be great if your app could run on this device properly.


#9  Ken Maltby 06-28-2014, 04:48 PM
First, I wish I could take credit for the results of the Koreader Project at Github, They are the ones that work the magic. You can see what they did and follow their progress at the site I linked to in the first post.

The navigation and functioning of Koreader in my Android v4.0.3 ASUS TF-101 is very snappy. I don't know if "more RAM" is needed on your device, this app doesn't come with any.

Perhaps you have a friend with your same device, and some limited skill, who could follow the description for porting the project to a particular device. Or at least establish why that device is having problems with it and my, relatively old tablet has no problems.

Note, you are the second poster who is having problems with it on that device, there may be something different with how the Onyx M96 works.


#10  rhari79 06-29-2014, 07:13 AM
I have tried this on multiple kitkat running devices: Z ultra, TF700t, but with no luck.
It just doesnt work.
With TF700, i can see the file open screen, but touches are greatly off the mark.never was able to select the correct folder.
With z ultra, it just hangs at the start.
(tried on multiple builds..6-Jun, 27-June etc.,)

Maybe kitkat is not supported??

Edit: I had an old kindle fire lying around; runs 2.3.4; Tried the Koreader on this and it works rather splendidly. So its probably the android version or device resolutions that cause it to hang.

  Next »  Last »  (1/36)
Today's Posts | Search this Thread | Login | Register